Gajim - 2020-02-25


  1. Eduard Ummm
  2. Eduard Latest gajim git doesn't look good
  3. Eduard https://share.conversations.im/edu4rdshl/GsdGxfFds63kwMWx/0178817f-db49-4e2a-aeda-501a8cd4e4e6.png
  4. Eduard Some buttons doesn't match the color
  5. Eduard Also when opening I got a completely blank window :$
  6. Eduard I mean
  7. Eduard https://share.conversations.im/edu4rdshl/VPsxIeNTtsE5FfT7/50032ba9-7629-465c-b3c6-0d87cbd1d8e8.png
  8. wurstsalat Eduard: that's probably you having set dark theme in gajim but not on your system? I had this while testing gajim in dark mode: set my system to dark, gajim to inherit system settings, and it looked like this. it needed a restart to look normal (manjaro kde)
  9. stefan Hello, I have now some gajim logs, because of omemo.
  10. stefan One client gajim, the other conversations. didn't send omemo encrypted yet. when I tried to send omemo enc. from gajim to conversations, there was only the message "‎Keine Geräte gefunden. Abfrage läuft..." (no devices found, query is running..). The other way round, it worked. when the conversations client sent a omemo encrypted message, I could trust the key in gajim, and send encrypted messages from then on.
  11. stefan but there are different clients, where omemo doesn't work at all.
  12. lovetox But that hints to a broken bundle node
  13. lovetox Stefan can you share the debug logs?
  14. stefan one moment..
  15. stefan https://paste.gajim.org/view/090f6124
  16. stefan I'm away for some time. I'll look back here in 1-2 hours. thanks in advance!
  17. stefan It's ejabberd 18.12
  18. stefan can that be repaired ? "broken bundle node" ?
  19. Eduard > Eduard: that's probably you having set dark theme in gajim but not on your system? I had this while testing gajim in dark mode: set my system to dark, gajim to inherit system settings, and it looked like this. it needed a restart to look normal (manjaro kde) wurstsalat: mmm would be. I was testing a DE and probably it has changed the gtk3 configuration
  20. Eduard Let me see quickly
  21. Eduard Mmm looks fine the config
  22. Eduard https://share.conversations.im/edu4rdshl/EbcCuwEICMPIaUgj/ce4e8b6a-0a29-4fef-8f4f-a9f3579a08cd.png
  23. Link Mauve Eduard, why not just gtk-application-prefer-dark-theme=1?
  24. Link Mauve Changing the theme name sounds weird for that.
  25. Eduard Link Mauve, fixed, was something in the colors.css created by Plasma
  26. Eduard Deleted these files and all is ok again. Thanks!
  27. lovetox Stefan I can only check it in the evening
  28. nifker how can I look at the server cert in gajim?
  29. bert nifker: Accounts --> Sever info --> Connection --> View certificate
  30. wurstsalat Eduard: where did that css reside? I'd like to test something :)
  31. Eduard > Eduard: where did that css reside? I'd like to test something :) wurstsalat: in `$HOME/.config/gtk-3.0/colors.css`
  32. Eduard But that module is called by another file (theme.css, though) that just do a `@import colors.css`
  33. Eduard wurstsalat: if you have Plasma installed try lsing $HOME/.config/gtk-3.0
  34. Eduard There should be 4 files
  35. Eduard Including the colors.css one
  36. stefan lovetox thank you!
  37. bodqhrohro The color of sent messages does not garmonize with the GTK+ theme, how can I garmonize it? In Pidgin there is the convcolors.so module to set the colors, but I can't find neither settings nor similar modules for Gajim.
  38. lovetox stefan, i see the problem, alle the keys are published to the server in a very wrong way, this can be because of the client, or maybe the server fucks something up
  39. lovetox can you name the version of the clients the "drago" user uses?
  40. wurstsalat bodqhrohro: Gajim > Preferences > Design > Themes > * Message Colors
  41. lovetox you have to close the chat control to see it working sometimes
  42. lovetox and you have to activate the theme after setting it in Preferences
  43. lovetox Stefan, im investigating this, please do not set any actions like delete keys, reset keys or etc on the clients
  44. lovetox this will most likely not help
  45. lovetox im in contact with the Conversations developer and i give you further instructions later or tomorrow how to debug this further
  46. bodqhrohro wurstsalat: lovefox: got it, I needed to create a theme; there was no one in list.
  47. stefan lovetox: great! thank you. Drago uses Gajim and Conversations. I for myself tested a windows phone 10 app, called uwpx, too.
  48. stefan and a nightly version of gajim.
  49. lovetox What version of gajim did drago use
  50. wurstsalat bodqhrohro: yes there will be a better workflow in the next version
  51. stefan I updated all versions from time to time. 1.1.3 at the moment, i think (64 bit windows)
  52. stefan the account itself is quite old. i remember we had im+ on windows phone for a time. but i think that didn't support omemo?
  53. lovetox stefan, i think this is a ejabberd problem
  54. lovetox it mixes up the pubsub requests
  55. lovetox its not only omemo nodes that look wrong
  56. lovetox i just joined the ejabberd support chat and asked how to fix this
  57. wurstsalat asterix, it seems like bot isn't working correctly