Gajim - 2020-01-19


  1. prof.p Hello, what is the proper workflow to get the nightlies of Gajim running under Linux incl the PlugIns?
  2. prof.p Simply downloading and compiling from here? https://gajim.org/downloads/snap/?M=D
  3. prof.p But where do I get the proper Plugins from?
  4. wurstsalat prof.p: depends on your linux! there are repos for nightly for debian/ubuntu, and there is an AUR for arch
  5. prof.p Manjaro here. So simply compiling from the AUR will make the latest nightly available? Is this "gajim-git" ? What else do I need? gajim-plugin-omemo-git? python-nbxmpp-git? Is this maintained? What about the other plugins?
  6. wurstsalat prof.p: last time I saw someone installing gajim nightly from AUR gajim-git + python-nbxmpp-git worked, but gajim-omemo-git did not. note that you have to uninstall other gajim versions first
  7. wurstsalat you may get plugins via ftp.gajim.org
  8. wurstsalat gajim master zip
  9. wurstsalat plugin_installer first, then you can install from there
  10. prof.p Thx
  11. wurstsalat have to check why gajim-omemo-git does't work
  12. prof.p wurstsalat: I am on Manjaro and willing to test if I can contribute somehow...
  13. wurstsalat prof.p: thanks! I'm using Manjaro as well, just didn't find the time to test yet :)
  14. wurstsalat ok, gajim-omemo-git seems to be a git package for current stable (Gajim 1.1.3). I asked if it could be updated
  15. Eduard wurstsalat: why you don't install it from the Gajim's plugin manager?
  16. wurstsalat Eduard, because dependencies get resolved for me when I use a package
  17. wurstsalat this is not about me, but about users trying to install gajim git + plugins via packages from AUR
  18. Eduard wurstsalat, -git packages doesn't need to be updated, if you want to have the latest version just rebuild the package.
  19. Eduard -git and VCS packages in general
  20. wurstsalat Eduard, I can't even install it, because it wants to install gajim 1.1.3 (which is gajim_1.1 branch, not master)
  21. Eduard I saw the PKGBUILD
  22. Eduard It sucks
  23. wurstsalat Eduard, are you able to improve it?
  24. Eduard Of course. The maintainer seems to be inactive, anyways we can fix the PKGBUILD. Let me do it in the night or tomorrow.
  25. wurstsalat Eduard, that would be much appreciated! :)
  26. Christian Hello, when I write from Gajim towards Pix-Art, the person does not receive a "message read" information. From PixArt to PixArt it works. What exactly do I have to set here?
  27. wurstsalat Christian: Gajim does not send this read marker yet. Next version will!
  28. hannibal asterix, could we get a flatpak repository for master branch? https://conference.gajim.org:5281/pastebin/13b7162a-24ea-4b3f-bfb2-1a9fe3e92e35
  29. Christian Thanks
  30. allie I keep getting a message saying "This message was encrypted with OMEMO but not for this device", and I can't figure out wtf is causing it
  31. allie like maybe it's from chat states or something? has anyone else run into this? if I log out of conversations it goes away, but I'm only getting it with one contact
  32. lovetox allie what Gajim version are you using
  33. Eduard > I keep getting a message saying "This message was encrypted with OMEMO but not for this device", and I can't figure out wtf is causing it Are the keys trusted?
  34. bot Philipp Hörist pushed 2 commits to branch _refs/heads/master_ of _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins >: https://conference.gajim.org:5281/pastebin/ebbb4b00-637b-44ff-9d7e-cb996950c61a
  35. bot Bronko updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/560 >: remove fuzzy time from conversation textview and include date in time_stamp
  36. bot Bronko updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/560 >: remove fuzzy time from conversation textview and include date in time_stamp
  37. prof.p allie: sounds to me like your contact has not validated all your fingerprints.
  38. allie prof.p: I can read the messages on both clients, though.
  39. lovetox allie, what Gajim version?
  40. allie lovetox: hmm, I thought I responded to that earlier. It's from git, 1.1.92, I'll have to lookup which commit it was built from
  41. prof.p You should check which is your actual fingerprint for your Gajim device. Then ask your contact if very fingerprint is in his list of active fingerprints and flagged as trusted.
  42. prof.p ...if *this* very fingerprint is...
  43. lovetox allie, i pushed a omemo update an hour ago
  44. lovetox upgrade to 2.6.73 and see if it still happens
  45. lovetox if it still happens, i need debug logs
  46. allie prof.p: wouldn't that mean I'd still get the message regardless of whether or not I also have Conversations connected? If I take Conversations offline, the error goes away, but I can still read the messages.
  47. allie lovetox: I'll give it a shot in a moment ☺️
  48. allie lovetox: okay, got the omemo update. the contact I was having problems with isn't online right now, but I'll let you know when I can see what happens.
  49. asterix hannibal: that seems easy to do. And the idea is to build a daily version like tarballs debian packages and windows build (and MacOS one day) ? I'll do some tests
  50. hannibal Yes, that should be the easiest. But if possible the repo could be updated with a push to master branch.
  51. wurstsalat hannibal: that would be nice to have :)