Gajim - 2018-10-26


  1. bot Philipp Hörist updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/333 >: gajim/logind_listener.py rectification
  2. bot Philipp Hörist updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/333 >: gajim/logind_listener.py rectification
  3. bot Philipp Hörist updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/333 >: gajim/logind_listener.py rectification
  4. bot Philipp Hörist updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/333 >: Improve logind listener
  5. bot Philipp Hörist pushed 1 commit to branch _refs/heads/master_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: https://conference.gajim.org:5281/pastebin/c65d2ea5-acec-4a07-a2a8-a0d153b26d6d
  6. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9357 >: #9357: < DBus org.freedesktop.login1 sleep handling >
  7. bot Philipp Hörist merged a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/333 >: Improve logind listener
  8. mm hi. is there any policy on releases of plugins? is https://ftp.gajim.org/plugins_releases/ an official repository for releases?
  9. mm and if so, please take a look at the releases there. they seem to be quite confusing. the acronyms_expander for example. but omemo too. there are multiple releases in short time with strange release numbers for omemo at least. and the acronyms_expander seems be release from different development branches.
  10. lovetox yes every gajim version has its plugin repo
  11. lovetox the release folder is only for distributions so they can link to older versions
  12. mm i try to write ebuilds for some plugins i want to use.
  13. lovetox for 1.0.3 look here https://ftp.gajim.org/plugins_1/
  14. mm ok
  15. lovetox for 1.1 https://ftp.gajim.org/plugins_1.1_zip/
  16. lovetox for master https://ftp.gajim.org/plugins_master_zip/
  17. mm well... i prefer plugins with versions. it makes it easier to write ebuilds.
  18. lovetox yes then use https://ftp.gajim.org/plugins_releases/
  19. lovetox version scheme is like gajim
  20. lovetox 1.2 = master
  21. lovetox 1.1 is gajim 1.1
  22. lovetox and so on
  23. mm ok
  24. mm thx
  25. lovetox on some plugins thats not the version scheme, then you have to look up here https://dev.gajim.org/gajim/gajim-plugins
  26. lovetox what version is in which branch
  27. mm maybe there is room for improvement her. :-)
  28. lovetox i dont see one, if a plugin has version 7.x we cant make it 1.x
  29. bot Philipp Hörist pushed 6 commits to branch _refs/heads/gajim_1.1_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: https://conference.gajim.org:5281/pastebin/36dc6ad0-2878-441f-a632-4e05b73fef41
  30. marmistrz GAjim crashes for me while trying to view some old chat history
  31. marmistrz https://conference.gajim.org:5281/pastebin/3ad9dd1c-a717-4383-a728-3122ee6a96fe
  32. marmistrz I'm using gtk3 3.24.1+8+g220f77d8c1-1 on Arch Linux, 1.0.3-3
  33. marmistrz I'm using gtk3 3.24.1+8+g220f77d8c1-1 on Arch Linux, gajim 1.0.3-3
  34. Daniel asterix, why is build always failing for gajim-plugins?
  35. lovetox and only then marmistrz ?
  36. marmistrz lovetox: I encounter it only while viewing the history for 7th Oct
  37. marmistrz for a specific contact
  38. marmistrz while looking at the other days, everything's fine
  39. lovetox disable all plugins
  40. lovetox and try again
  41. bot Buntbart1 created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9404 >: #9404: < Plugin-Installer deletes PlugIns >
  42. bot Daniel Brötzmann closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9404 >: #9404: < Plugin-Installer deletes PlugIns >
  43. bot Andriy Kushnir created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9405 >: #9405: < PGP plugin can't decrypt private key with non-ascii passphrase >
  44. bot Philipp Hörist created an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/357 >: #357: < PGP plugin can't decrypt private key with non-ascii passphrase >
  45. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9405 >: #9405: < PGP plugin can't decrypt private key with non-ascii passphrase >
  46. Orhideous Hi. How can I submit pull request to gajim repo? Via good old patches? I can't fork repository by now.
  47. lovetox whats your username Orhideous
  48. Orhideous lovetox, https://dev.gajim.org/orhideous
  49. lovetox should work now
  50. bot Andriy Kushnir proposed a new merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/348 >: Slightly refactored passphrase verification
  51. bot Andriy Kushnir updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/348 >: Slightly refactored passphrase verification
  52. Orhideous lovetox, thanks! I just forked repo and extracted some logic from common/connection.py to more appropriate (imho) place. This is OK?
  53. lovetox yes
  54. lovetox what im not sure about is your solution to the problem
  55. lovetox So you verified that GPG Keys can only have ascii passwords?
  56. Orhideous In my case, I have a pre-check for correct passphrase encoding
  57. Orhideous Yes, because latin-1 hardcoded in original gnupg distribution
  58. Orhideous And, in such cases test_passphrase return GPGKeyState.BROKEN_PASSPHRASE_ENCODING, what considered as error (or user mistake)
  59. Orhideous Strictly speaking, in my case it was just a mistake, I forgot to switch the keyboard layout.
  60. lovetox but gpg keys can have passphrases with non ascii chars
  61. lovetox this makes it impossible to use the key with gajim
  62. lovetox there is a ACE config option called "pgp_encoding"
  63. lovetox you could try and set it to "utf-8" and see if that works
  64. asterix BTW this option and all gpg code should go to plugin, no?
  65. lovetox yes but the legacy pgp has also a lot of GUI code in gajim
  66. bot Marek Walczak created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9406 >: #9406: < cannot trust/revoke uindecided omemo key >
  67. bot Marek Walczak modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9406 >: #9406: < cannot trust/revoke omemo key >
  68. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9406 >: #9406: < cannot trust/revoke omemo key >
  69. Orhideous lovetox, ok, I'll fix it tomorrow.
  70. bot Andriy Kushnir updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/348 >: WIP: Slightly refactored passphrase verification