Gajim - 2018-06-16


  1. bot Daniel modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9198 >: #9198: < Creating new muc's with capital letters is not possible >
  2. mrDoctorWho Gajim fetches all the groupchat history without a special request for it and I must wait for it to fetch it all before sending any message, because the history scrolls really fast. That's insane guys, I think Gajim shouldn't fetch all history (for example, it had to fetch history for 46 days for this groupchat)
  3. mrDoctorWho Also gajim doesn't seem to rejoin groupchats after a reconnect, which is really sad
  4. mrDoctorWho I'm on the latest commit in master for Jun 6 2018
  5. andrey.g mrDoctorWho‎ > Also gajim doesn't seem to rejoin groupchats after a reconnect, which is really sad Did you also experience #9173?
  6. mrDoctorWho andrey.g, it seems so, although my connection icon is kinda crazy. Any connection problems cause it to freeze in "connecting" state
  7. Daniel mrDoctorWho, history loading is on the list of things
  8. bot zak333 modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9198 >: #9198: < Creating new mucs with capital letters is not possible >
  9. pvoigt Could anybody please give a hint. Under Debian Stretch I am getting today: "The following packages have unmet dependencies: python3-nbxmpp-nightly : Conflicts: python3-nbxmpp but 0.6.6-1 is to be installed E: Broken packages"
  10. pvoigt My current Gajim is: 1.0.2+f99ec91fc
  11. pitchum pvoigt, it seems that you have installed gajim-default-nightly, is there a reason why you did not install gajim-nightly instead?
  12. pvoigt pitchum, hm, I am not even aware that there are two versions. My apt source is "deb https://ftp.gajim.org/debian unstable main" What is the difference an how should I change?
  13. pitchum try this: sudo apt install gajim-nightly gajim-default-nightly-
  14. pvoigt ...will omit trailing "-", right?
  15. pvoigt Unfortunately, this gives the same dependency error.
  16. pvoigt pitchum, just checked via apt show and dpkg: It looks like I have gajim-nightly installed - and not gajim-default-nightly.
  17. pitchum weird, then try to find which package depends on python3-nbxmpp-nightly
  18. pitchum apt rdepends python3-nbxmpp-nightly
  19. pvoigt # apt rdepends python3-nbxmpp-nightly python3-nbxmpp-nightly Reverse Depends: Depends: gajim-default-nightly (>= 20160905) Depends: gajim-nightly (>= 20160905)
  20. pvoigt # dpkg -l |grep python3-nbxmpp ii python3-nbxmpp-nightly 20180529-1 all Non blocking XMPP Python library
  21. pitchum weird, I don't have the same results here: apt rdepends python3-nbxmpp-nightly python3-nbxmpp-nightly Reverse Depends: Depends: gajim-default-nightly (>= 20160905)
  22. pitchum did you "apt update" recently?
  23. pvoigt Oh yes, always before any apt upgrade ;-)
  24. pvoigt To my understanding so far: The new gajim needs python3-nbxmpp_0.6.6-1_all.deb which cannot be installed for unknown reason.
  25. pvoigt So I did an apt test run - should to see how apt handles dependencies: "apt remove python3-nbxmpp-nightly" It looks like this would not only remove the current python3-nbxmpp-nightly but would even upgrade gajim-nightly. This is strange, because apt should handle the upgrade of gajim without a deinstall of depending libraries.
  26. pitchum actually gajim-nightly requires python3-nbxmpp to be removed
  27. pvoigt I suppose this is because of an unknown name change aka mismatch: The new gajim-nightly now wants python3-nbxmpp instead of python3-nbxmpp-nightly. Is this name change intended?
  28. pitchum try to uninstall python3-nbxmpp
  29. pvoigt python3-nbxmpp in not installed on my system (see above for details). Instead I have python3-nbxmpp-nightly which is obviously too old.
  30. pvoigt OK, as supposed: "apt remove python3-nbxmpp-nightly" did the trick. Now I have python3-nbxmpp and gajim-nightly installed in latest versions.
  31. pvoigt Will restart Gajim now with fingers crossed...
  32. pitchum :)
  33. pvoigt pitchum, OK, I am back with running Gajim 1.0.3+0ab9d1210. Thanks so far.
  34. pitchum something I still don't understand is why the command "apt rdepends python3-nbxmpp-nightly" yields different results
  35. pvoigt pitchum, right, still strange.
  36. bot Alexander Krotov proposed a new merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/270 >: Do not forward encrypted messages on XEP-0146 requests
  37. bot Alexander Krotov updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/270 >: Do not forward encrypted messages on XEP-0146 requests
  38. bot Alexander Krotov proposed a new merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/271 >: Fix docstrings for XEP-0146 commands
  39. bot Alexander Krotov updated a merge request for _gajim/master_ < https://dev.gajim.org/gajim/gajim/merge_requests/268 >: Set secure_delete pragma for SQLite3 connections
  40. Link Mauve 0146 is obsoleted because it’s highly insecure, why is it still part of Gajim? :/
  41. link2xt Well, at least it is disabled by default
  42. link2xt If you did not enable "remote_commands" manually, everything is good
  43. link2xt It is not insecure as long as you don't expose commands that server cannot do on your behalf
  44. link2xt Commands like "change status to away" are not a problem
  45. link2xt But "send all unread messages in plaintext" is
  46. link2xt I would vote for removal of XEP-0146 support though