Gajim - 2018-03-30


  1. benrob0329 Getting this error when trying to install flatpack: Failed to download sources: module gajim: Wrong sha256 checksum for plugin_installer.zip, expected a4ee63a4b7fd213236f30f23ff0535d63bad2fd276363d4ac8d320da63d4d09c, was 4831f44dc7c88b892b93dac893a5f95e65b8625e4994f7205287fe1aef3afd92
  2. benrob0329 patches the shasum
  3. benrob0329 should just submit a pr for that
  4. benrob0329 hmm, seems the build fails too
  5. benrob0329 Could not find a version that satisfies the requirement nbxmpp>=0.6.4 (from gajim==1.0.0+a5dd159ad841) (from versions: ) No matching distribution found for nbxmpp>=0.6.4 (from gajim==1.0.0+a5dd159ad841)
  6. UsL flatpak is a sad thing come to linux...
  7. UsL it's like a bunch of windows user idiots switched to linux but missed the messed up program installation routine and made it work on linux
  8. benrob0329 I don't know that I would say that
  9. benrob0329 Its a package manager, just one that is independent of the base
  10. benrob0329 Could be useful for giving stable distros new sofrware
  11. benrob0329 And for once we can have one package format...
  12. Asterix benrob0329: ha yes, new version and I should have received a mail to remimd me to change sha. It seems scipt is wrong ...
  13. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/8009 >: #8009: < Useful buttons in balloon notifications >
  14. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/8006 >: #8006: < Roster contacts get hidden and a Traceback on account removal. >
  15. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7787 >: #7787: < Error on startup >
  16. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7530 >: #7530: < fix translated strings >
  17. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7819 >: #7819: < No ppa released for Ubuntu 14.04.x "trusty" >
  18. Link Mauve Asterix, better have versioned versions of the zip file, and point the flatpak build script to a specific version.
  19. Asterix There is a new version on every commit
  20. Link Mauve Maybe add a commit hook which will update the checksum?
  21. Link Mauve If you want to keep it manual, versioning “releases” (which would be 1:1 with commits) is still the way to go.
  22. Link Mauve So that people on a slightly older version can still build it, otherwise you’re destroying reproducible builds.
  23. Asterix I already added a commit hook that send me a mail (but it doesn't work it seems. But automatic commits, not sure I like that ...
  24. Link Mauve Automatic changes, with manual approval.
  25. Link Mauve Or something like that.
  26. Link Mauve Sending you an email is worthless for people who are stuck with a non-working build file.
  27. Asterix I mean send me a mail when there is an update so I change the fingerprint
  28. Link Mauve Why wouldn’t you just keep the older versions, and point to them?
  29. Link Mauve So that when you receive the email, you will update both the checksum and the version.
  30. Link Mauve Version can be as simple as "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)" for instance.
  31. Link Mauve Or just an incrementing number.
  32. bot Daniel modified an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/186 >: #186: < [httpupload] Add upload button to contact right-click menu >
  33. n00b Seems I've broken ipython shell. I forgot to close a bracket and now it doesn't interact with me. CTRL+C doesn't help
  34. Asterix Link Mauve, there is a version in manifest file
  35. Asterix n00b, change you computer then ;)
  36. Link Mauve Asterix, I’m asking for a version in the URL.
  37. Link Mauve So that we know what we’re downloading.
  38. n00b Asterix: no
  39. n00b Built-in python shell handles it well
  40. Asterix Link Mauve, yes, I know. But tthat could be the version that is in the manifest file. But anyway, I don't want to have all versions of all plugins ...
  41. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9020 >: #9020: < outdated requirements >
  42. Asterix Daniel, don't you have the rights to close tickets?
  43. bot Yann Leboulanger closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/175 >: #175: < [gajim-otr]: Merge github/gajim-otr and gajim-plugins/gotr development >
  44. n00b What version of IPython lib do you have?
  45. n00b Mine is "6.2.1"
  46. Daniel Asterix, yes I have, but I'm still new to this so I though asking first would be appropriate. will close issues myself in the future, if I'm absolutely sure about it :)
  47. Asterix n00b, None on this machine
  48. Asterix Daniel, ok nice. And we still receive mails when tickets are changed / close, so we'll reopen if we think it's appropriiate
  49. n00b I have to know it is ipython or gajim error
  50. Asterix Daniel, BTW thanks for your work in filtering tickets and in wiki
  51. Daniel I'm glad I can help!
  52. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/8827 >: #8827: < "ValueError: Invalid format string" timestamp issue >
  53. bot Daniel closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/167 >: #167: < python-axolotl from Ubuntu 16.04 repos usable for OMEMO >
  54. Link Mauve Asterix, why?
  55. Link Mauve You already have them in git anyway, so it should be easy to generate them automatically.
  56. Link Mauve Also, I think the issue was only about plugins installed by default in the flatpak build for now.
  57. bot Daniel closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/147 >: #147: < 0.16.6-1 From the pictures sent via http-upload only last one shown clicking one time on each of them >
  58. bot Daniel modified an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/142 >: #142: < Show send/received pictures/files inline >
  59. bot Daniel closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/104 >: #104: < Query Bot >
  60. bot Volunteer created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9023 >: #9023: < Ipython shell window doesn't interact after getting an unexpected bracket >
  61. Asterix Link Mauve, easy ... I don't know, but doable, yes for sure. On every commit, you have to look which files changed and if in manifest, the version changed, and if so save the zip. and then were to store that correctly, one folder per plugin? one folder with all version of all plugins?
  62. Asterix n00b, ipython is really for developpers, not for users. So if you do a mistake there, you restart Gajim and that's it, I don't think we'll take time to see where the problem is
  63. Link Mauve Creating folders is cheap. :p
  64. n00b How do i start debugging if your debugging code works wrong itself?
  65. Asterix n00b, debugging code works if you type correctly
  66. n00b Have you never misspelled?
  67. Asterix of course, but then I correct my code and restart my gajim test instance
  68. Asterix I'm not saying it's a good behaviour to stay in this state
  69. Asterix just that devs can accept to restart Gajim if they do a mistake
  70. bot Daniel closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/91 >: #91: < OTR plugin does not always encrypt >
  71. n00b Asterix: dont close it, please
  72. bot Daniel closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/83 >: #83: < dont open juick chat window >
  73. bot Philipp Hörist closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/185 >: #185: < View/download omemo encrypted image/file in history >
  74. lovetox n00b this is a messenger client, please only report problems that you experience why using it while communicating with other people
  75. lovetox Gajim is not a python learning class
  76. lovetox *while
  77. bot Daniel modified an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/39 >: #39: < additional action: urgency notification >
  78. lovetox Neustradamus, please try https://ci.appveyor.com/project/lovetox/gajim/build/job/physm6t8khwnn4r3/artifacts
  79. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7808 >: #7808: < Deprecate ACE in favor to dconf Editor >
  80. bot Volunteer modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9023 >: #9023: < Ipython shell window doesn't interact after getting an unexpected bracket >
  81. n00b lovetox: please, see the updated issue
  82. lovetox supply a patch if its important to you
  83. n00b The reason is simple. For example you need to reproduce all the steps from bug report, you're doing this and that, then suddenly you have mispelled, and only thing you can to do is restart gajim and repeat all the steps again.
  84. bot Philipp Hörist pushed 1 commit to branch _refs/heads/master_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: *2ff96ad7* < https://dev.gajim.org/gajim/gajim/commit/2ff96ad7936c16ebed49c397c517edbda528f2d8 > Provide 64bit installer for Windows
  85. Link Mauve Is there any benefit to that, btw?
  86. lovetox not that i know of
  87. Daniel lovetox, there is an issue open about x64 which can be closed then :)
  88. lovetox lets wait until Asterix build the installer and added it to the website
  89. Daniel Asterix, could you pull updated translations when updating the website?
  90. n00b lovetox, https://paste.gajim.org/view/6b83b7bc
  91. aiti Gajim 1.0 doesn't seem to save the position of the window between program starts, at least on my triple monitor setup. It always pops up on the far left monitor even when it lives on the far right all the time.
  92. aiti Am I doing something wrong or should I put in a bug?
  93. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9023 >: #9023: < Ipython shell window doesn't interact after getting an unexpected bracket >
  94. bot Philipp Hörist pushed 1 commit to branch _refs/heads/master_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: *634cbd93* < https://dev.gajim.org/gajim/gajim/commit/634cbd93a8fcc535992d12b594667e1e4f441aab > Remove not supported methods Methods have been remove in from IPython since 2016 https://github.com/ipython/ipython/commit/b7d03ed6b16013973b82c4725c79c30ac0a84903#diff-3ffc5a89fb88284fe9b5787b8859140b Fixes #9023
  95. Daniel aiti, this is fixed in git master
  96. lovetox yeah we should get 1.0.1 out
  97. nico lovetox, (Y)
  98. aiti Daniel, cool, guess I'll wait for next release then
  99. bot DeSaurus created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  100. bot DeSaurus modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  101. bot DeSaurus modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  102. bot DeSaurus modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  103. bot DeSaurus modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  104. bot DeSaurus modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9024 >: #9024: < Downloading Files uploaded by http-upload fails on self signed certificate even though httpupload_verify is Deactivated >
  105. bot Daniel created an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/290 >: #290: < GPG should be opportunistically enabled >
  106. bot Daniel closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7486 >: #7486: < GPG should be opportunistically enabled >
  107. bot Daniel modified an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/290 >: #290: < GPG should be opportunistically enabled >
  108. bot Daniel modified an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7470 >: #7470: < Minor UI corrections/suggestions (Post 0.16) >
  109. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7476 >: #7476: < Replace pixmap with text where possible >
  110. Neustradamus About the problem of languages with Windows: https://bugzilla.gnome.org/show_bug.cgi?id=753991 + https://gitlab.gnome.org/GNOME/gtk/issues/128
  111. bot Daniel closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/3995 >: #3995: < Actions for text: translate to >
  112. marek hi, i am on ubuntu 17.10. I had a running gajim 0.16.8 with omemo. Today I upgraded gajim to 1.0.0-3 from gajim repositories. unfortunately the omemo-plugins complains about a non-installed or outdated python-axolotl package.
  113. lovetox did you install gajim from the gajim repos
  114. lovetox or debian?
  115. marek from gajim repos
  116. marek ubuntu does not have the new ones
  117. bot Daniel closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7196 >: #7196: < Incorrect self nickname in History (Direct and Private) >
  118. marek my python-axolotl version is 0.1.39-3
  119. lovetox ok, then you need all omemo dependencys but in python3
  120. lovetox python3-axolotl
  121. lovetox python3-protobuf
  122. marek aah :)
  123. lovetox python3-cryptography
  124. lovetox i hope the names are correct, but you get the idea
  125. marek i am gonna check, but sounds good
  126. Link Mauve lovetox, I just thought, why don’t you package plugins in this repository, and make them recommended?
  127. lovetox in what repo?
  128. Link Mauve So that users wouldn’t have to use the plugin manager, and would automatically have the correct dependencies.
  129. Link Mauve Your Debian repository.
  130. lovetox it is
  131. lovetox but gajim is not in debian stable
  132. lovetox so he has no access
  133. marek @lovetox: it did work like a charm, thx
  134. Link Mauve marek is using your repository, so why don’t they have it?
  135. lovetox ah thats what you mean
  136. marek because keeping up all the dependencies might be very tideous
  137. lovetox then we would have to package plugins .. hmm
  138. lovetox yeah we could do that for some of them
  139. Link Mauve Not all of them, you can reference the ones already present in the official Debian repositories.
  140. Link Mauve lovetox, didn’t Debian already do most of that work?
  141. lovetox yeah i guess
  142. Link Mauve You could just import their debian/ directory.
  143. lovetox yeah is a good idea
  144. lovetox maybe Asterix wants to do that for the most used plugins
  145. marek or at least point in the deb-package to the dependencies
  146. Daniel that would be nice!
  147. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7306 >: #7306: < Changing policies in packaging Windows Installer >
  148. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7228 >: #7228: < memory leak on Win2008R2 >
  149. bot Daniel closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/6961 >: #6961: < List of participants >
  150. bot Daniel closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/5866 >: #5866: < Any JID information retrival >
  151. bot villeneuve created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9025 >: #9025: < The portable installer should have an uninstaller included >
  152. bot villeneuve created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9026 >: #9026: < Make the chat window scrollable with the keyboard and show scroll-arrow-buttons >
  153. bot villeneuve created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9027 >: #9027: < Relocate the "Install/Upgrade"-button in the "Plugins"-window >
  154. Asterix I'm not against doing that, but I need to script all that so builds are done daily or on every commit ...
  155. bot moppman created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9028 >: #9028: < XEP-0163: #publish-options in "Server Info"? >
  156. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9028 >: #9028: < XEP-0163: #publish-options in "Server Info"? >
  157. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/7153 >: #7153: < Render LaTeX PNGs on transparent background >
  158. bot Marek Walczak created an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9029 >: #9029: < AttributeError: 'NoneType' object has no attribute 'setRaw' >
  159. rom1dep lovetox: ping?
  160. lovetox jo
  161. rom1dep you remember that ipython shell? I think it get stalled if I generate an error through it.
  162. Asterix fixed a few hours ago :)
  163. rom1dep Asterix: what?
  164. Asterix #9023
  165. rom1dep it takes so damn long to load gitlab
  166. bot Yann Leboulanger created an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/291 >: #291: < Relocate the "Install/Upgrade"-button in the "Plugins"-window >
  167. bot Yann Leboulanger closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9027 >: #9027: < Relocate the "Install/Upgrade"-button in the "Plugins"-window >
  168. rom1dep ah crap, I thought I was running master, but I'm running lovetox/master and it doesn't have the fix, yet :)
  169. rom1dep that's timely indeed, thanks Asterix, lovetox
  170. bot Yann Leboulanger pushed 1 commit to branch _refs/heads/master_ of _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins >: *ed08d107* < https://dev.gajim.org/gajim/gajim-plugins/commit/ed08d107a2b0a5e4759dc191f5e9487ab4a7d08c > mive install/upgrade button. Fixes #291
  171. bot Yann Leboulanger closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/291 >: #291: < Relocate the "Install/Upgrade"-button in the "Plugins"-window >
  172. rom1dep the fix seems to work 👍
  173. bot Yann Leboulanger pushed 1 commit to branch _refs/heads/master_ of _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins >: *ca06bbec* < https://dev.gajim.org/gajim/gajim-plugins/commit/ca06bbec4ec4eb4f6c5661087d839981e36d2441 > [plugin installer] bump version number
  174. bot Yann Leboulanger pushed 1 commit to branch _refs/heads/master_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: *644bdd9c* < https://dev.gajim.org/gajim/gajim/commit/644bdd9c769bc9de8e3a10c093e2aae8d22270a6 > update plugin installer sha256 for flatpak
  175. rom1dep how can I programatically get a client (app) name and version form a `gajim.common.contacts.Contact`?
  176. Asterix it's not saved in Gajim. When we want to display it, we request it and show the result, but don't store the result.
  177. rom1dep is there an api to make this request?
  178. Asterix app.connections[acct_name].request_os_info(jid, resource)
  179. rom1dep wowh ,there is a bunch of stuff in there, thanks, I'll try to find my way :)
  180. Asterix rom1dep, nice you go inside Gajim's code, you'll soon fix every tickets ;)
  181. rom1dep Asterix: I started with the easy task of updating client_icons.py to add "Conversations Legacy"
  182. rom1dep but then I realized that invoking ._node isn't an approach that can work to distinguish Conversations and Conversations Legacy
  183. rom1dep so even that simple thing leaves me wondering :) request_os_info returns None
  184. Asterix ha if you want the result you have to register to the version-result-received event
  185. Asterix app.ged.register_event_handler('version-result-received', ged.GUI1, callback)
  186. Asterix in the callback you'll get info
  187. Asterix see the set_os_info function in vcard.py
  188. rom1dep okkay
  189. Asterix all is asynchronous
  190. rom1dep how can I get it printed in my ipython shell, then?
  191. Asterix you write a callback function
  192. rom1dep the callback would be something like lambda x: print(x)
  193. Asterix and print in it
  194. Asterix but why do you do that with ipython?
  195. Asterix look at XML console
  196. rom1dep I want to update the client_icons.py code
  197. rom1dep so I need to do it programatically
  198. Asterix print x.client_info
  199. Asterix the callback get an object as parameter
  200. Asterix it's a VersionResultReceivedEvent event
  201. Asterix all events are defined in common/connection_handlers_event.py
  202. Asterix they are also listed there (may be a bit outdated)
  203. Asterix https://dev.gajim.org/gajim/gajim/wikis/development/PluginsEvents
  204. rom1dep it's not clear for me how request_os_info gets wired to my callback?
  205. Asterix rom1dep, not sure it's easier in ipython rather that changin plugin's code and restart Gajim
  206. bot Philipp Hörist created an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/292 >: #292: < AttributeError: 'NoneType' object has no attribute 'setRaw' >
  207. bot Philipp Hörist closed an issue in _gajim_ < https://dev.gajim.org/gajim/gajim/issues/9029 >: #9029: < AttributeError: 'NoneType' object has no attribute 'setRaw' >
  208. rom1dep but how can you even develop plugins in these conditions :)
  209. Asterix 1/ you register the callback 2/ request_os_info Then Gajim sends the request, receive the reply, parse it, extract info, and call all registered callback, so that calls your previously registered callback
  210. bot Philipp Hörist modified an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/292 >: #292: < OMEMO Groupchat problems >
  211. lovetox rom1dep, see the plugin tracker
  212. lovetox there is a MR for client icons
  213. lovetox where it has not the ability to differentiate between versions
  214. lovetox your going about it the wrong way
  215. rom1dep so I have `app.ged.register_event_handler('version-result-received', ged.GUI1, lambda x: print(x.client_info))` and `app.connections['account'].request_os_info('myjid', 'phone')`
  216. lovetox we dont do request_os on every client
  217. lovetox that would be insane
  218. lovetox clients tell us with there presence what client they are
  219. rom1dep lovetox: I want to branch out when I encounter `http://conversations.im`
  220. lovetox clients tell us with their presence what client they are
  221. lovetox first, you should analyze a conversations presence
  222. lovetox is there even a possibility in there
  223. lovetox that lets us differeniate?
  224. rom1dep yes
  225. lovetox can you post it?
  226. rom1dep Conversations Legacy 1.23.9 is what I get from the infos
  227. lovetox yes with the MR we can do it
  228. lovetox though you want to give it a other icon?!
  229. rom1dep yup
  230. lovetox i can merge the MR
  231. lovetox then you can add Conversations Legacy
  232. rom1dep just managed to open the MR, my wireless is slooooow
  233. lovetox just look at the Pixart Messenger entry
  234. lovetox and add you conversation entry like that
  235. lovetox this should work
  236. lovetox but only name it Conversations Legacy
  237. bot Philipp Hörist updated a merge request for _gajim-plugins/master_ < https://dev.gajim.org/gajim/gajim-plugins/merge_requests/73 >: [clients_icons] Readd support for roster tooltips and other gajim 0.16 features
  238. lovetox so tested it rom1dep
  239. lovetox ?
  240. rom1dep not yet
  241. lovetox if you tell me it works i will merge
  242. bot Yann Leboulanger pushed 12 commits to branch _refs/heads/gajim_1.0_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: https://conference.gajim.org:5281/pastebin/f1b1c581-e0d8-4ee8-9955-d3e666f9de66
  243. rom1dep icons are no longer showing-up in the MUC roster
  244. rom1dep not sure if it's intended…
  245. rom1dep https://upload.tamytro.org/upload/a3849b367f4dd4cedd5ad6f64afa7645b7d4f834/K5qF6NPlZlVF1jF5Y8KywyPLvVcIioPOC0epcfCd/client_icons.png
  246. rom1dep otherwise, it seems to work
  247. lovetox no is not intended ok i look into it and try to merge this soon
  248. rom1dep lovetox: You must understand that clients icons are the topmostüberultimate priority 😉
  249. rom1dep /s
  250. lovetox :D
  251. n00b please, move this issue https://dev.gajim.org/gajim/gajim-plugins/issues/287 into gajim repo
  252. n00b the problem in file https://dev.gajim.org/gajim/gajim/blob/master/gajim/common/gpg.py
  253. lovetox no this file is not used
  254. lovetox gpg is a plugin
  255. n00b i've made a patch
  256. n00b problem is in gajim repo
  257. n00b https://dev.gajim.org/gajim/gajim/blob/master/gajim/common/gpg.py#L76
  258. n00b replace line 76 with `return result.data.decode("utf8")`
  259. lovetox oh yeah i see, the plugin uses that file in gajim source
  260. lovetox wonder i it was never moved to the plugin
  261. lovetox ok thanks for testing
  262. bot Philipp Hörist pushed 1 commit to branch _refs/heads/master_ of _gajim_ < https://dev.gajim.org/gajim/gajim >: *e326aabf* < https://dev.gajim.org/gajim/gajim/commit/e326aabf5f0e33eb5a12530c6db424cab1694874 > Decode PGP decrypted messages
  263. bot Philipp Hörist closed an issue in _gajim-plugins_ < https://dev.gajim.org/gajim/gajim-plugins/issues/287 >: #287: < Encoding gets broken >