Gajim - 2017-11-12


  1. lovetox Dirk, priority has nothing to do with it
  2. lovetox Dirk, priority has nothing to do with it
  3. lovetox Dirk, priority has nothing to do with it
  4. lovetox the server sends all messages to all clients
  5. lovetox the server sends all messages to all clients
  6. lovetox the server sends all messages to all clients
  7. lovetox if you dont seem to receive a message in chatsecure its most likely it is received but could not be decrypted
  8. lovetox if you dont seem to receive a message in chatsecure its most likely it is received but could not be decrypted
  9. lovetox if you dont seem to receive a message in chatsecure its most likely it is received but could not be decrypted
  10. lovetox does it work the other way around, if you send a message from chatsecure, do you receive it in gajim?
  11. lovetox does it work the other way around, if you send a message from chatsecure, do you receive it in gajim?
  12. lovetox does it work the other way around, if you send a message from chatsecure, do you receive it in gajim?
  13. lovetox mimi89999, i dont know what you are talking about, there is no "Add Bookmark" menu, inside Accounts menu
  14. lovetox mimi89999, i dont know what you are talking about, there is no "Add Bookmark" menu, inside Accounts menu
  15. lovetox mimi89999, i dont know what you are talking about, there is no "Add Bookmark" menu, inside Accounts menu
  16. Dirk lovetox, thanks for the clarification on priority. To answer your question, yes, I am able to receive OMEMO messages the other way (from ChatSecure to Gajim/Conversations)
  17. Dirk lovetox, thanks for the clarification on priority. To answer your question, yes, I am able to receive OMEMO messages the other way (from ChatSecure to Gajim/Conversations)
  18. Dirk lovetox, thanks for the clarification on priority. To answer your question, yes, I am able to receive OMEMO messages the other way (from ChatSecure to Gajim/Conversations)
  19. lovetox and you are sure the fingerprint that belongs to chatsecure is trusted in gajim
  20. lovetox and you are sure the fingerprint that belongs to chatsecure is trusted in gajim
  21. lovetox and you are sure the fingerprint that belongs to chatsecure is trusted in gajim
  22. Dirk Also when ChatSecure is the only client connected for that user, OMEMO messages are received just fine
  23. Dirk Also when ChatSecure is the only client connected for that user, OMEMO messages are received just fine
  24. Dirk Also when ChatSecure is the only client connected for that user, OMEMO messages are received just fine
  25. Dirk Yep. Definitely sure on that
  26. Dirk Yep. Definitely sure on that
  27. Dirk Yep. Definitely sure on that
  28. lovetox hm then this really sounds like your server or chatsecure does not enable carbons
  29. lovetox hm then this really sounds like your server or chatsecure does not enable carbons
  30. lovetox hm then this really sounds like your server or chatsecure does not enable carbons
  31. lovetox the thing that makes sure all messages get delivered to all clients
  32. lovetox the thing that makes sure all messages get delivered to all clients
  33. lovetox the thing that makes sure all messages get delivered to all clients
  34. lovetox but you told me it works unencrypted?
  35. lovetox but you told me it works unencrypted?
  36. lovetox but you told me it works unencrypted?
  37. Dirk Well unencrypted everything is peachy.
  38. Dirk Well unencrypted everything is peachy.
  39. Dirk Well unencrypted everything is peachy.
  40. Dirk Yea. Seems to be related to OMEMO
  41. Dirk Yea. Seems to be related to OMEMO
  42. Dirk Yea. Seems to be related to OMEMO
  43. lovetox but i cant imagine what causes this, so you are saying all 3 clients are online, and chatsecure receives nothing, but as soon as you go offline with conversations it starts working?
  44. lovetox but i cant imagine what causes this, so you are saying all 3 clients are online, and chatsecure receives nothing, but as soon as you go offline with conversations it starts working?
  45. lovetox but i cant imagine what causes this, so you are saying all 3 clients are online, and chatsecure receives nothing, but as soon as you go offline with conversations it starts working?
  46. Dirk So if client A is using Gajim/ChatSecure and I send a message to him from Gajim, only his Gajim client receives the message. If client A were to log off of Gajim (but stay on ChatSecure), messages still won't be received by ChatSecure until a message is sent by that client with ChatSecure. However, after that point, everything works great with only ChatSecure logged in
  47. Dirk So if client A is using Gajim/ChatSecure and I send a message to him from Gajim, only his Gajim client receives the message. If client A were to log off of Gajim (but stay on ChatSecure), messages still won't be received by ChatSecure until a message is sent by that client with ChatSecure. However, after that point, everything works great with only ChatSecure logged in
  48. Dirk So if client A is using Gajim/ChatSecure and I send a message to him from Gajim, only his Gajim client receives the message. If client A were to log off of Gajim (but stay on ChatSecure), messages still won't be received by ChatSecure until a message is sent by that client with ChatSecure. However, after that point, everything works great with only ChatSecure logged in
  49. Dirk It's really bizarre and confusing...
  50. Dirk It's really bizarre and confusing...
  51. Dirk It's really bizarre and confusing...
  52. lovetox for me there are only 2 things i can think of
  53. lovetox for me there are only 2 things i can think of
  54. lovetox for me there are only 2 things i can think of
  55. lovetox 1. chatsecure does not handle copied messages (carbons) if they are encrypted for some reason
  56. lovetox 1. chatsecure does not handle copied messages (carbons) if they are encrypted for some reason
  57. lovetox 1. chatsecure does not handle copied messages (carbons) if they are encrypted for some reason
  58. lovetox 2. your server does not copy encrypted messages to other clients
  59. lovetox 2. your server does not copy encrypted messages to other clients
  60. lovetox 2. your server does not copy encrypted messages to other clients
  61. lovetox either way this is possibly best debuged on chatsecure
  62. lovetox either way this is possibly best debuged on chatsecure
  63. lovetox either way this is possibly best debuged on chatsecure
  64. lovetox you should find out if the message really never arrives (server fault)
  65. lovetox you should find out if the message really never arrives (server fault)
  66. lovetox you should find out if the message really never arrives (server fault)
  67. lovetox or if it arrives and cant be decrypted
  68. lovetox or if it arrives and cant be decrypted
  69. lovetox or if it arrives and cant be decrypted
  70. lovetox to rule the server out, you could test the whole thing with accounts on a different server
  71. lovetox to rule the server out, you could test the whole thing with accounts on a different server
  72. lovetox to rule the server out, you could test the whole thing with accounts on a different server
  73. lovetox for example jabber.at i know has no problems that way
  74. lovetox for example jabber.at i know has no problems that way
  75. lovetox for example jabber.at i know has no problems that way
  76. Dirk Good advice. I'll try a different server and see if I can narrow it down to my server
  77. Dirk Good advice. I'll try a different server and see if I can narrow it down to my server
  78. Dirk Good advice. I'll try a different server and see if I can narrow it down to my server
  79. Dirk Thanks!
  80. Dirk Thanks!
  81. Dirk Thanks!
  82. jh Macht nix
  83. jh Macht nix
  84. jh Macht nix
  85. jh 😸
  86. jh 😸
  87. jh 😸
  88. mimi89999 lovetox: In account there is join a room and there there is again join a room and there you can add room info and select add bookmark.
  89. mimi89999 lovetox: In account there is join a room and there there is again join a room and there you can add room info and select add bookmark.
  90. mimi89999 lovetox: In account there is join a room and there there is again join a room and there you can add room info and select add bookmark.
  91. lovetox so you actually mean the join groupchat window
  92. lovetox so you actually mean the join groupchat window
  93. lovetox so you actually mean the join groupchat window
  94. lovetox weird i added today 3-4 bookmarks over that window, never have a problem
  95. lovetox weird i added today 3-4 bookmarks over that window, never have a problem
  96. lovetox weird i added today 3-4 bookmarks over that window, never have a problem
  97. lovetox can you reproduce it 100%
  98. lovetox can you reproduce it 100%
  99. lovetox can you reproduce it 100%
  100. lovetox ?
  101. lovetox ?
  102. lovetox ?
  103. mimi89999 yes
  104. mimi89999 yes
  105. mimi89999 yes
  106. lovetox i have a mam for muc nearly finished
  107. lovetox i have a mam for muc nearly finished
  108. lovetox i have a mam for muc nearly finished
  109. lovetox only some polishing is left
  110. lovetox only some polishing is left
  111. lovetox only some polishing is left
  112. lovetox and it even shows the messages inside the chatwindow, not only history :)
  113. lovetox and it even shows the messages inside the chatwindow, not only history :)
  114. lovetox and it even shows the messages inside the chatwindow, not only history :)
  115. lep \o/
  116. lep \o/
  117. lep \o/
  118. ThibG 👍
  119. ThibG 👍
  120. ThibG 👍
  121. ThibG hm, I'm still rebasing my workaround patch that unconditionally displays all groups (but not all the contacts within) even if they are empty… has there been any progress on the weird Gtk3 issue?
  122. ThibG hm, I'm still rebasing my workaround patch that unconditionally displays all groups (but not all the contacts within) even if they are empty… has there been any progress on the weird Gtk3 issue?
  123. ThibG hm, I'm still rebasing my workaround patch that unconditionally displays all groups (but not all the contacts within) even if they are empty… has there been any progress on the weird Gtk3 issue?
  124. debacle A Debian users complains about Gajim not connecting again after wakeup from suspend. Both 0.16.8 and master. Known problem?
  125. debacle A Debian users complains about Gajim not connecting again after wakeup from suspend. Both 0.16.8 and master. Known problem?
  126. debacle A Debian users complains about Gajim not connecting again after wakeup from suspend. Both 0.16.8 and master. Known problem?
  127. debacle bugs.debian.org/881304
  128. debacle bugs.debian.org/881304
  129. debacle bugs.debian.org/881304
  130. debacle https://bugs.debian.org/881304
  131. debacle https://bugs.debian.org/881304
  132. debacle https://bugs.debian.org/881304
  133. lovetox hm i operated under the assumption that if you suspend your system that connection drops
  134. lovetox hm i operated under the assumption that if you suspend your system that connection drops
  135. lovetox hm i operated under the assumption that if you suspend your system that connection drops
  136. lovetox and network manager would announce that
  137. lovetox and network manager would announce that
  138. lovetox and network manager would announce that
  139. lovetox but it seems that is not the case
  140. lovetox but it seems that is not the case
  141. lovetox but it seems that is not the case
  142. lovetox which is a bit weird
  143. lovetox which is a bit weird
  144. lovetox which is a bit weird
  145. Link Mauve lovetox, you may want to replace the NetworkManager-specific implementation with a GLib-based one, taking inspiration from this patch: https://bugs.webkit.org/show_bug.cgi?id=177741
  146. Link Mauve lovetox, you may want to replace the NetworkManager-specific implementation with a GLib-based one, taking inspiration from this patch: https://bugs.webkit.org/show_bug.cgi?id=177741
  147. Link Mauve lovetox, you may want to replace the NetworkManager-specific implementation with a GLib-based one, taking inspiration from this patch: https://bugs.webkit.org/show_bug.cgi?id=177741
  148. lovetox hm yeah but if this solves the problem is not clear
  149. lovetox hm yeah but if this solves the problem is not clear
  150. lovetox hm yeah but if this solves the problem is not clear
  151. Tomek Hi, I am using latest nightly in chroot and can't get rid of this error: (E) gajim.gtkgui_helpers Unable to load icon document-edit-symbolic: pygi-error: unknown error (0) Could it be the reason I do not see MAM working?
  152. Tomek Hi, I am using latest nightly in chroot and can't get rid of this error: (E) gajim.gtkgui_helpers Unable to load icon document-edit-symbolic: pygi-error: unknown error (0) Could it be the reason I do not see MAM working?
  153. Tomek Hi, I am using latest nightly in chroot and can't get rid of this error: (E) gajim.gtkgui_helpers Unable to load icon document-edit-symbolic: pygi-error: unknown error (0) Could it be the reason I do not see MAM working?
  154. Link Mauve It would at least try to solve it for every user not using NetworkManager.
  155. Link Mauve It would at least try to solve it for every user not using NetworkManager.
  156. Link Mauve It would at least try to solve it for every user not using NetworkManager.
  157. lovetox Tomek it seems you have a too old adwaita-icon-theme
  158. lovetox Tomek it seems you have a too old adwaita-icon-theme
  159. lovetox Tomek it seems you have a too old adwaita-icon-theme
  160. lovetox also please state the gajim version from help->about
  161. lovetox also please state the gajim version from help->about
  162. lovetox also please state the gajim version from help->about
  163. lovetox and the gtk version
  164. lovetox and the gtk version
  165. lovetox and the gtk version
  166. Tomek gajim 0.16.11.1; A GTK+ XMPP client GTK+ Version: 3.22.24 PyGObject Version: 3.24.1 python-nbxmpp Version: 0.6.0
  167. Tomek gajim 0.16.11.1; A GTK+ XMPP client GTK+ Version: 3.22.24 PyGObject Version: 3.24.1 python-nbxmpp Version: 0.6.0
  168. Tomek gajim 0.16.11.1; A GTK+ XMPP client GTK+ Version: 3.22.24 PyGObject Version: 3.24.1 python-nbxmpp Version: 0.6.0
  169. lovetox good :)
  170. lovetox good :)
  171. lovetox good :)
  172. lovetox go to accounts -> advanced -> serverinfo
  173. lovetox go to accounts -> advanced -> serverinfo
  174. lovetox go to accounts -> advanced -> serverinfo
  175. lovetox and see what the part about mam says
  176. lovetox and see what the part about mam says
  177. lovetox and see what the part about mam says
  178. lovetox hover over it to see the mam version that is in effect
  179. lovetox hover over it to see the mam version that is in effect
  180. lovetox hover over it to see the mam version that is in effect
  181. Tomek lovetox, when I hove over line "XEP-0313: Message Archive Management" I see "urn:xmpp:mam:2"; I use prosody 0.10.0
  182. Tomek lovetox, when I hove over line "XEP-0313: Message Archive Management" I see "urn:xmpp:mam:2"; I use prosody 0.10.0
  183. Tomek lovetox, when I hove over line "XEP-0313: Message Archive Management" I see "urn:xmpp:mam:2"; I use prosody 0.10.0
  184. lovetox so mam should work
  185. lovetox so mam should work
  186. lovetox so mam should work
  187. lovetox are you sure it does not work? gajim doesnt show history inside the chatwindow
  188. lovetox are you sure it does not work? gajim doesnt show history inside the chatwindow
  189. lovetox are you sure it does not work? gajim doesnt show history inside the chatwindow
  190. lovetox you have to open the history window
  191. lovetox you have to open the history window
  192. lovetox you have to open the history window
  193. Tomek I see nothing there; conversations works fine with MAM on same server
  194. Tomek I see nothing there; conversations works fine with MAM on same server
  195. Tomek I see nothing there; conversations works fine with MAM on same server
  196. Tomek what is otehr way to do the test?
  197. Tomek what is otehr way to do the test?
  198. Tomek what is otehr way to do the test?
  199. lovetox do you have encrption enabled?
  200. lovetox do you have encrption enabled?
  201. lovetox do you have encrption enabled?
  202. Tomek lovetox, I just executed "synchronise history one month" which I did not notice earleir and still nothing; yeap, that was the question I just wanted to ask. I look at the conversation with contact which was OEMO enabled. In this cllient I can not have it enabled as it say: all plugins are not compatible with this version.
  203. Tomek lovetox, I just executed "synchronise history one month" which I did not notice earleir and still nothing; yeap, that was the question I just wanted to ask. I look at the conversation with contact which was OEMO enabled. In this cllient I can not have it enabled as it say: all plugins are not compatible with this version.
  204. Tomek lovetox, I just executed "synchronise history one month" which I did not notice earleir and still nothing; yeap, that was the question I just wanted to ask. I look at the conversation with contact which was OEMO enabled. In this cllient I can not have it enabled as it say: all plugins are not compatible with this version.
  205. lovetox you cant sync old omemo conversations
  206. lovetox you cant sync old omemo conversations
  207. lovetox you cant sync old omemo conversations
  208. lovetox thats not possible with that encryption
  209. lovetox thats not possible with that encryption
  210. lovetox thats not possible with that encryption
  211. Tomek but I should see at leat some info that this conversation is encrypted, no?
  212. Tomek but I should see at leat some info that this conversation is encrypted, no?
  213. Tomek but I should see at leat some info that this conversation is encrypted, no?
  214. Tomek so I need to enable OMEMO first?
  215. Tomek so I need to enable OMEMO first?
  216. Tomek so I need to enable OMEMO first?
  217. lovetox no
  218. lovetox no
  219. lovetox no
  220. lovetox omemo has perfect forward secrecy
  221. lovetox omemo has perfect forward secrecy
  222. lovetox omemo has perfect forward secrecy
  223. lovetox you cant encrypt old messages
  224. lovetox you cant encrypt old messages
  225. lovetox you cant encrypt old messages
  226. lovetox its just impossible
  227. lovetox its just impossible
  228. lovetox its just impossible
  229. lovetox *decrypt
  230. lovetox *decrypt
  231. lovetox *decrypt
  232. Tomek I meant if I enable OMEMO I will have MAM working for future messages?
  233. Tomek I meant if I enable OMEMO I will have MAM working for future messages?
  234. Tomek I meant if I enable OMEMO I will have MAM working for future messages?
  235. lovetox yes
  236. lovetox yes
  237. lovetox yes
  238. Tomek OK so how to do it with this version if plugin does not work?
  239. Tomek OK so how to do it with this version if plugin does not work?
  240. Tomek OK so how to do it with this version if plugin does not work?
  241. lovetox what system?
  242. lovetox what system?
  243. lovetox what system?
  244. Tomek mint 18.1 + chroot artful
  245. Tomek mint 18.1 + chroot artful
  246. Tomek mint 18.1 + chroot artful
  247. lovetox hm bad, i guess you have to download it from here
  248. lovetox hm bad, i guess you have to download it from here
  249. lovetox hm bad, i guess you have to download it from here
  250. lovetox https://ftp.gajim.org/plugins_1/omemo.zip
  251. lovetox https://ftp.gajim.org/plugins_1/omemo.zip
  252. lovetox https://ftp.gajim.org/plugins_1/omemo.zip
  253. lovetox put it into the plugins folder
  254. lovetox put it into the plugins folder
  255. lovetox put it into the plugins folder
  256. lovetox ~/.local/share/gajim/plugins
  257. lovetox ~/.local/share/gajim/plugins
  258. lovetox ~/.local/share/gajim/plugins
  259. lovetox and install all dependencys
  260. lovetox and install all dependencys
  261. lovetox and install all dependencys
  262. lovetox python-cryptography
  263. lovetox python-cryptography
  264. lovetox python-cryptography
  265. lovetox python-axolotl
  266. lovetox python-axolotl
  267. lovetox python-axolotl
  268. lovetox python-protobuf
  269. lovetox python-protobuf
  270. lovetox python-protobuf
  271. cippaciong lovetox, I tested your commit and it works :)
  272. cippaciong lovetox, I tested your commit and it works :)
  273. cippaciong lovetox, I tested your commit and it works :)
  274. lovetox then i push a new version today
  275. lovetox then i push a new version today
  276. lovetox then i push a new version today
  277. cippaciong Thanks!
  278. cippaciong Thanks!
  279. cippaciong Thanks!
  280. mimi89999 lovetox: You found the issue?
  281. mimi89999 lovetox: You found the issue?
  282. mimi89999 lovetox: You found the issue?
  283. lovetox no mimi89999 i cannot reproduce your issue
  284. lovetox no mimi89999 i cannot reproduce your issue
  285. lovetox no mimi89999 i cannot reproduce your issue
  286. lovetox does it happen with any muc you specify?
  287. lovetox does it happen with any muc you specify?
  288. lovetox does it happen with any muc you specify?
  289. lovetox or server
  290. lovetox or server
  291. lovetox or server
  292. mimi89999 With any
  293. mimi89999 With any
  294. mimi89999 With any
  295. rom1dep > and it even shows the messages inside the chatwindow, not only history :) lovetox: ♥️
  296. rom1dep > and it even shows the messages inside the chatwindow, not only history :) lovetox: ♥️
  297. rom1dep > and it even shows the messages inside the chatwindow, not only history :) lovetox: ♥️
  298. rom1dep Is it mam-version agnostic?
  299. rom1dep Is it mam-version agnostic?
  300. rom1dep Is it mam-version agnostic?
  301. lovetox hm no, gajim will only support mam:1 and mam:2
  302. lovetox hm no, gajim will only support mam:1 and mam:2
  303. lovetox hm no, gajim will only support mam:1 and mam:2
  304. rom1dep That should be good enough for any reasonably recent prosody/ejabberd IIUC
  305. rom1dep That should be good enough for any reasonably recent prosody/ejabberd IIUC
  306. rom1dep That should be good enough for any reasonably recent prosody/ejabberd IIUC
  307. Tomek lovetox, following your earlier advices, I have problems with protobuf. When running gajim I get: (E) gajim.plugin_system.omemo module 'google.protobuf.descriptor_pool' has no attribute 'Default' pip(3) list shows: python3-protobuf (2.5.0) but I installed manually from sources v.3.4: Extracting protobuf-3.4.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages protobuf 3.4.0 is already the active version in easy-install.pth (...) Using /usr/lib/python2.7/dist-packages Finished processing dependencies for protobuf==3.4.0 What is wrong?
  308. Tomek lovetox, following your earlier advices, I have problems with protobuf. When running gajim I get: (E) gajim.plugin_system.omemo module 'google.protobuf.descriptor_pool' has no attribute 'Default' pip(3) list shows: python3-protobuf (2.5.0) but I installed manually from sources v.3.4: Extracting protobuf-3.4.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages protobuf 3.4.0 is already the active version in easy-install.pth (...) Using /usr/lib/python2.7/dist-packages Finished processing dependencies for protobuf==3.4.0 What is wrong?
  309. Tomek lovetox, following your earlier advices, I have problems with protobuf. When running gajim I get: (E) gajim.plugin_system.omemo module 'google.protobuf.descriptor_pool' has no attribute 'Default' pip(3) list shows: python3-protobuf (2.5.0) but I installed manually from sources v.3.4: Extracting protobuf-3.4.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages protobuf 3.4.0 is already the active version in easy-install.pth (...) Using /usr/lib/python2.7/dist-packages Finished processing dependencies for protobuf==3.4.0 What is wrong?
  310. lovetox you did install to python2
  311. lovetox you did install to python2
  312. lovetox you did install to python2
  313. lovetox gajim uses python3
  314. lovetox gajim uses python3
  315. lovetox gajim uses python3
  316. lovetox Tomek,
  317. lovetox Tomek,
  318. lovetox Tomek,
  319. Tomek lovetox, OK, got confused. So now I believe I removed protobuf-2.5 - pip list: asn1crypto (0.22.0) cryptography (1.9) gajim (0.16.11.1) idna (2.5) nbxmpp (0.6.0) olefile (0.44) Pillow (4.1.1) pip (9.0.1) pyasn1 (0.1.9) pycrypto (2.6.1) pygi (1.0.3) pygobject (3.24.1) pyOpenSSL (16.2.0) python-axolotl (0.1.39) python-axolotl-curve25519 (0.1) python-gnupg (0.3.8) python-Levenshtein (0.12.0) PyYAML (3.12) setuptools (36.7.1) six (1.11.0) wheel (0.29.0) and reinstalled again protobuf-3.4 from sources - sudo -H python3 setup.py install: (...) Processing protobuf-3.4.0-py3.6.egg removing '/usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg' (and everything under it) creating /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Extracting protobuf-3.4.0-py3.6.egg to /usr/local/lib/python3.6/site-packages protobuf 3.4.0 is already the active version in easy-install.pth Installed /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Processing dependencies for protobuf==3.4.0 Searching for setuptools==28.8.0 Best match: setuptools 28.8.0 Adding setuptools 28.8.0 to easy-install.pth file Installing easy_install script to /usr/local/bin Installing easy_install-3.5 script to /usr/local/bin Using /usr/local/lib/python3.6/site-packages Searching for six==1.11.0 Best match: six 1.11.0 Processing six-1.11.0-py3.6.egg six 1.11.0 is already the active version in easy-install.pth Using /usr/local/lib/python3.6/site-packages/six-1.11.0-py3.6.egg Finished processing dependencies for protobuf==3.4.0 and when I run gajim I see below and OMEMO does not work... (E) gajim.plugin_system.omemo No module named 'google.protobuf.message' does it mean it can't find protobuf or is it wrong version? Or I miss something still?
  320. Tomek lovetox, OK, got confused. So now I believe I removed protobuf-2.5 - pip list: asn1crypto (0.22.0) cryptography (1.9) gajim (0.16.11.1) idna (2.5) nbxmpp (0.6.0) olefile (0.44) Pillow (4.1.1) pip (9.0.1) pyasn1 (0.1.9) pycrypto (2.6.1) pygi (1.0.3) pygobject (3.24.1) pyOpenSSL (16.2.0) python-axolotl (0.1.39) python-axolotl-curve25519 (0.1) python-gnupg (0.3.8) python-Levenshtein (0.12.0) PyYAML (3.12) setuptools (36.7.1) six (1.11.0) wheel (0.29.0) and reinstalled again protobuf-3.4 from sources - sudo -H python3 setup.py install: (...) Processing protobuf-3.4.0-py3.6.egg removing '/usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg' (and everything under it) creating /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Extracting protobuf-3.4.0-py3.6.egg to /usr/local/lib/python3.6/site-packages protobuf 3.4.0 is already the active version in easy-install.pth Installed /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Processing dependencies for protobuf==3.4.0 Searching for setuptools==28.8.0 Best match: setuptools 28.8.0 Adding setuptools 28.8.0 to easy-install.pth file Installing easy_install script to /usr/local/bin Installing easy_install-3.5 script to /usr/local/bin Using /usr/local/lib/python3.6/site-packages Searching for six==1.11.0 Best match: six 1.11.0 Processing six-1.11.0-py3.6.egg six 1.11.0 is already the active version in easy-install.pth Using /usr/local/lib/python3.6/site-packages/six-1.11.0-py3.6.egg Finished processing dependencies for protobuf==3.4.0 and when I run gajim I see below and OMEMO does not work... (E) gajim.plugin_system.omemo No module named 'google.protobuf.message' does it mean it can't find protobuf or is it wrong version? Or I miss something still?
  321. Tomek lovetox, OK, got confused. So now I believe I removed protobuf-2.5 - pip list: asn1crypto (0.22.0) cryptography (1.9) gajim (0.16.11.1) idna (2.5) nbxmpp (0.6.0) olefile (0.44) Pillow (4.1.1) pip (9.0.1) pyasn1 (0.1.9) pycrypto (2.6.1) pygi (1.0.3) pygobject (3.24.1) pyOpenSSL (16.2.0) python-axolotl (0.1.39) python-axolotl-curve25519 (0.1) python-gnupg (0.3.8) python-Levenshtein (0.12.0) PyYAML (3.12) setuptools (36.7.1) six (1.11.0) wheel (0.29.0) and reinstalled again protobuf-3.4 from sources - sudo -H python3 setup.py install: (...) Processing protobuf-3.4.0-py3.6.egg removing '/usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg' (and everything under it) creating /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Extracting protobuf-3.4.0-py3.6.egg to /usr/local/lib/python3.6/site-packages protobuf 3.4.0 is already the active version in easy-install.pth Installed /usr/local/lib/python3.6/site-packages/protobuf-3.4.0-py3.6.egg Processing dependencies for protobuf==3.4.0 Searching for setuptools==28.8.0 Best match: setuptools 28.8.0 Adding setuptools 28.8.0 to easy-install.pth file Installing easy_install script to /usr/local/bin Installing easy_install-3.5 script to /usr/local/bin Using /usr/local/lib/python3.6/site-packages Searching for six==1.11.0 Best match: six 1.11.0 Processing six-1.11.0-py3.6.egg six 1.11.0 is already the active version in easy-install.pth Using /usr/local/lib/python3.6/site-packages/six-1.11.0-py3.6.egg Finished processing dependencies for protobuf==3.4.0 and when I run gajim I see below and OMEMO does not work... (E) gajim.plugin_system.omemo No module named 'google.protobuf.message' does it mean it can't find protobuf or is it wrong version? Or I miss something still?
  322. lovetox try installing it from your package manager
  323. lovetox try installing it from your package manager
  324. lovetox try installing it from your package manager
  325. lovetox site-packages is probably not going to work, as your system searches in dist-packages
  326. lovetox site-packages is probably not going to work, as your system searches in dist-packages
  327. lovetox site-packages is probably not going to work, as your system searches in dist-packages
  328. lovetox but there should be a protobuf package in your distribution repos
  329. lovetox but there should be a protobuf package in your distribution repos
  330. lovetox but there should be a protobuf package in your distribution repos
  331. lovetox dont need to install it from pip
  332. lovetox dont need to install it from pip
  333. lovetox dont need to install it from pip
  334. Tomek lovetox, sudo apt-get install python-protobuf Reading package lists... Done Building dependency tree Reading state information... Done python-protobuf is already the newest version (2.6.1-1.3). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  335. Tomek lovetox, sudo apt-get install python-protobuf Reading package lists... Done Building dependency tree Reading state information... Done python-protobuf is already the newest version (2.6.1-1.3). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  336. Tomek lovetox, sudo apt-get install python-protobuf Reading package lists... Done Building dependency tree Reading state information... Done python-protobuf is already the newest version (2.6.1-1.3). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  337. lovetox again not python3
  338. lovetox again not python3
  339. lovetox again not python3
  340. lovetox python3-protobuf
  341. lovetox python3-protobuf
  342. lovetox python3-protobuf
  343. Tomek sudo apt-get install python3-protobuf Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python3-protobuf
  344. Tomek sudo apt-get install python3-protobuf Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python3-protobuf
  345. Tomek sudo apt-get install python3-protobuf Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python3-protobuf
  346. lovetox then find out whatever the package is for python3protobuf on your distribution
  347. lovetox then find out whatever the package is for python3protobuf on your distribution
  348. lovetox then find out whatever the package is for python3protobuf on your distribution
  349. lovetox try installing
  350. lovetox try installing
  351. lovetox try installing
  352. lovetox python3-axolotl
  353. lovetox python3-axolotl
  354. lovetox python3-axolotl
  355. lovetox it should have dependency on protobuf
  356. lovetox it should have dependency on protobuf
  357. lovetox it should have dependency on protobuf
  358. lovetox at least its in the ubunut repos
  359. lovetox at least its in the ubunut repos
  360. lovetox at least its in the ubunut repos
  361. lovetox https://launchpad.net/ubuntu/+source/python-axolotl
  362. lovetox https://launchpad.net/ubuntu/+source/python-axolotl
  363. lovetox https://launchpad.net/ubuntu/+source/python-axolotl
  364. lovetox is mint using the ubuntu repos?
  365. lovetox is mint using the ubuntu repos?
  366. lovetox is mint using the ubuntu repos?
  367. lovetox python3-protobuf does maybe not exist because mint 18 is too old
  368. lovetox python3-protobuf does maybe not exist because mint 18 is too old
  369. lovetox python3-protobuf does maybe not exist because mint 18 is too old
  370. lovetox or on what ubuntu version does mint depend?
  371. lovetox or on what ubuntu version does mint depend?
  372. lovetox or on what ubuntu version does mint depend?
  373. Tomek I am chrooted to ubuntu artful
  374. Tomek I am chrooted to ubuntu artful
  375. Tomek I am chrooted to ubuntu artful
  376. lovetox but it seems not to the repos
  377. lovetox but it seems not to the repos
  378. lovetox but it seems not to the repos
  379. lovetox https://packages.ubuntu.com/zesty/python3-protobuf
  380. lovetox https://packages.ubuntu.com/zesty/python3-protobuf
  381. lovetox https://packages.ubuntu.com/zesty/python3-protobuf
  382. lovetox https://packages.ubuntu.com/artful/python3-protobuf
  383. lovetox https://packages.ubuntu.com/artful/python3-protobuf
  384. lovetox https://packages.ubuntu.com/artful/python3-protobuf
  385. bronko Wikipedia says Mint 18.x is based on Ubuntu 16.04 (xenial) which has no python3-protobuf as far as i can tell
  386. bronko Wikipedia says Mint 18.x is based on Ubuntu 16.04 (xenial) which has no python3-protobuf as far as i can tell
  387. bronko Wikipedia says Mint 18.x is based on Ubuntu 16.04 (xenial) which has no python3-protobuf as far as i can tell
  388. Tomek so it means gajim 10.8 uses python2 ? as it works
  389. Tomek so it means gajim 10.8 uses python2 ? as it works
  390. Tomek so it means gajim 10.8 uses python2 ? as it works
  391. Tomek you were both right, I did mess up my packages sources. After fixing, everything got installed and gajim runs with OMEMO
  392. Tomek you were both right, I did mess up my packages sources. After fixing, everything got installed and gajim runs with OMEMO
  393. Tomek you were both right, I did mess up my packages sources. After fixing, everything got installed and gajim runs with OMEMO
  394. Tomek thanks
  395. Tomek thanks
  396. Tomek thanks
  397. lovetox mimi89999, it seems you have a bookmark in your bookmarks that messes gajim up
  398. lovetox mimi89999, it seems you have a bookmark in your bookmarks that messes gajim up
  399. lovetox mimi89999, it seems you have a bookmark in your bookmarks that messes gajim up
  400. mimi89999 😮
  401. mimi89999 😮
  402. mimi89999 😮
  403. lovetox can you check your bookmarks in Gajim -> Bookmarks
  404. lovetox can you check your bookmarks in Gajim -> Bookmarks
  405. lovetox can you check your bookmarks in Gajim -> Bookmarks
  406. lovetox see if anyone of them maybe seems odd
  407. lovetox see if anyone of them maybe seems odd
  408. lovetox see if anyone of them maybe seems odd
  409. lovetox missing some fields maybe
  410. lovetox missing some fields maybe
  411. lovetox missing some fields maybe
  412. mimi89999 Can only do that tomorrow...
  413. mimi89999 Can only do that tomorrow...
  414. mimi89999 Can only do that tomorrow...