Gajim - 2017-11-09


  1. svesa set the topic to Welcome to the official room of Gajim. Gajim 0.16.8 is now released! Try it! Language is English. If you have something to ask, just ask. Don't circle around with questions like "Have anyone used Gajim on Windows?"... New bugs at https://dev.gajim.org/gajim/gajim/issues New bugs about a plugin at https://dev.gajim.org/gajim/gajim-plugins/issues Paste in https://paste.gajim.org shots in http://picpaste.com room logs in https://conference.gajim.org:5281/muc_log/gajim/ Spread Gajim! https://dev.gajim.org/gajim/gajim/wikis/community/SpreadJabberAndGajim GSOC: xmpp:gsoc@conference.conversations.im?join
  2. svesa set the topic to Welcome to the official room of Gajim. Gajim 0.16.8 is now released! Try it! Language is English. If you have something to ask, just ask. Don't circle around with questions like "Have anyone used Gajim on Windows?"... New bugs at https://dev.gajim.org/gajim/gajim/issues New bugs about a plugin at https://dev.gajim.org/gajim/gajim-plugins/issues Paste in https://paste.gajim.org shots in http://picpaste.com room logs in https://conference.gajim.org:5281/muc_log/gajim/ Spread Gajim! https://dev.gajim.org/gajim/gajim/wikis/community/SpreadJabberAndGajim GSOC: xmpp:gsoc@conference.conversations.im?join
  3. svesa set the topic to Welcome to the official room of Gajim. Gajim 0.16.8 is now released! Try it! Language is English. If you have something to ask, just ask. Don't circle around with questions like "Have anyone used Gajim on Windows?"... New bugs at https://dev.gajim.org/gajim/gajim/issues New bugs about a plugin at https://dev.gajim.org/gajim/gajim-plugins/issues Paste in https://paste.gajim.org shots in http://picpaste.com room logs in https://conference.gajim.org:5281/muc_log/gajim/ Spread Gajim! https://dev.gajim.org/gajim/gajim/wikis/community/SpreadJabberAndGajim GSOC: xmpp:gsoc@conference.conversations.im?join
  4. Tschaeggaer hello
  5. Tschaeggaer hello
  6. Tschaeggaer hello
  7. Tschaeggaer what would it take to have Gajim on Windows support audio and video chat?
  8. Tschaeggaer what would it take to have Gajim on Windows support audio and video chat?
  9. Tschaeggaer what would it take to have Gajim on Windows support audio and video chat?
  10. Link Mauve Tschaeggaer, hi, mostly someone who uses Windows and is interested in maintaining that.
  11. Link Mauve Tschaeggaer, hi, mostly someone who uses Windows and is interested in maintaining that.
  12. Link Mauve Tschaeggaer, hi, mostly someone who uses Windows and is interested in maintaining that.
  13. Tschaeggaer I am interested in that and using windows since I play windows-only games. I thought about joining an open source project a while now, why shouldn't it be gajim... But I'll need to learn python first. I did Java, but only very few lines in python, plus I only ever programmed very very little things for myself. But I guess you need to start somewhere...
  14. Tschaeggaer I am interested in that and using windows since I play windows-only games. I thought about joining an open source project a while now, why shouldn't it be gajim... But I'll need to learn python first. I did Java, but only very few lines in python, plus I only ever programmed very very little things for myself. But I guess you need to start somewhere...
  15. Tschaeggaer I am interested in that and using windows since I play windows-only games. I thought about joining an open source project a while now, why shouldn't it be gajim... But I'll need to learn python first. I did Java, but only very few lines in python, plus I only ever programmed very very little things for myself. But I guess you need to start somewhere...
  16. Link Mauve Heh, I guess that’s a nice project, don’t hesitate to ask here if you need help on anything.
  17. Link Mauve Heh, I guess that’s a nice project, don’t hesitate to ask here if you need help on anything.
  18. Link Mauve Heh, I guess that’s a nice project, don’t hesitate to ask here if you need help on anything.
  19. Tschaeggaer sure. first thing will probably be to have a close look at the code.
  20. Tschaeggaer sure. first thing will probably be to have a close look at the code.
  21. Tschaeggaer sure. first thing will probably be to have a close look at the code.
  22. mdosch Traceback (most recent call last): File "/usr/lib/python3/dist-packages/gi/overrides/GLib.py", line 728, in <lambda> func_fdtransform = lambda _, cond, *data: callback(channel, cond, *data) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 549, in _process_events return IdleQueue._process_events(self, fd, flags) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 409, in _process_events obj.pollin() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 446, in pollin self._do_receive() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 669, in _do_receive self._on_receive(received) File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 683, in _on_receive self.on_receive(data) File "/usr/lib/python3/dist-packages/nbxmpp/dispatcher_nb.py", line 531, in _WaitForData resp(self._owner, _iq, **args) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 480, in _parse_vcard stanza.getTag('vCard', namespace=nbxmpp.NS_VCARD)) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 362, in _node_to_dict for info in node.getChildren(): AttributeError: 'NoneType' object has no attribute 'getChildren'
  23. mdosch Traceback (most recent call last): File "/usr/lib/python3/dist-packages/gi/overrides/GLib.py", line 728, in <lambda> func_fdtransform = lambda _, cond, *data: callback(channel, cond, *data) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 549, in _process_events return IdleQueue._process_events(self, fd, flags) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 409, in _process_events obj.pollin() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 446, in pollin self._do_receive() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 669, in _do_receive self._on_receive(received) File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 683, in _on_receive self.on_receive(data) File "/usr/lib/python3/dist-packages/nbxmpp/dispatcher_nb.py", line 531, in _WaitForData resp(self._owner, _iq, **args) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 480, in _parse_vcard stanza.getTag('vCard', namespace=nbxmpp.NS_VCARD)) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 362, in _node_to_dict for info in node.getChildren(): AttributeError: 'NoneType' object has no attribute 'getChildren'
  24. mdosch Traceback (most recent call last): File "/usr/lib/python3/dist-packages/gi/overrides/GLib.py", line 728, in <lambda> func_fdtransform = lambda _, cond, *data: callback(channel, cond, *data) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 549, in _process_events return IdleQueue._process_events(self, fd, flags) File "/usr/lib/python3/dist-packages/nbxmpp/idlequeue.py", line 409, in _process_events obj.pollin() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 446, in pollin self._do_receive() File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 669, in _do_receive self._on_receive(received) File "/usr/lib/python3/dist-packages/nbxmpp/transports_nb.py", line 683, in _on_receive self.on_receive(data) File "/usr/lib/python3/dist-packages/nbxmpp/dispatcher_nb.py", line 531, in _WaitForData resp(self._owner, _iq, **args) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 480, in _parse_vcard stanza.getTag('vCard', namespace=nbxmpp.NS_VCARD)) File "/usr/lib/python3/dist-packages/gajim/common/connection_handlers.py", line 362, in _node_to_dict for info in node.getChildren(): AttributeError: 'NoneType' object has no attribute 'getChildren'
  25. mdosch gajim-default-nightly/unstable,unstable,unstable,now 20171109-1
  26. mdosch gajim-default-nightly/unstable,unstable,unstable,now 20171109-1
  27. mdosch gajim-default-nightly/unstable,unstable,unstable,now 20171109-1
  28. lovetox haha omg
  29. lovetox haha omg
  30. lovetox haha omg
  31. mdosch Something weird
  32. mdosch Something weird
  33. mdosch Something weird
  34. lovetox no none check, i must have been really tired yesterday
  35. lovetox no none check, i must have been really tired yesterday
  36. lovetox no none check, i must have been really tired yesterday
  37. mdosch What's wrong?
  38. mdosch What's wrong?
  39. mdosch What's wrong?
  40. lovetox hm could you do me a favor and put a "print(stanza) into line 478 of connection_handlers.py
  41. lovetox hm could you do me a favor and put a "print(stanza) into line 478 of connection_handlers.py
  42. lovetox hm could you do me a favor and put a "print(stanza) into line 478 of connection_handlers.py
  43. lovetox then start from console and wait for the exception
  44. lovetox then start from console and wait for the exception
  45. lovetox then start from console and wait for the exception
  46. lovetox and tell me what it prints right before
  47. lovetox and tell me what it prints right before
  48. lovetox and tell me what it prints right before
  49. mdosch will try
  50. mdosch will try
  51. mdosch will try
  52. mdosch No error message this time. You are interested in terminal output?
  53. mdosch No error message this time. You are interested in terminal output?
  54. mdosch No error message this time. You are interested in terminal output?
  55. lovetox if there was no exception than not
  56. lovetox if there was no exception than not
  57. lovetox if there was no exception than not
  58. lovetox if there was no exception then not
  59. lovetox if there was no exception then not
  60. lovetox if there was no exception then not
  61. lovetox but i know how to fix this, it seems some old ejabbered answer wrong to our vcard requests
  62. lovetox but i know how to fix this, it seems some old ejabbered answer wrong to our vcard requests
  63. lovetox but i know how to fix this, it seems some old ejabbered answer wrong to our vcard requests
  64. mdosch looks like there is still the error, but I didn't get a crash popup this time
  65. mdosch looks like there is still the error, but I didn't get a crash popup this time
  66. mdosch looks like there is still the error, but I didn't get a crash popup this time
  67. mdosch Sent you a pm
  68. mdosch Sent you a pm
  69. mdosch Sent you a pm
  70. lovetox yeah thanks
  71. lovetox yeah thanks
  72. lovetox yeah thanks
  73. lovetox weird
  74. lovetox weird
  75. lovetox weird
  76. lovetox yeah i investigate this
  77. lovetox yeah i investigate this
  78. lovetox yeah i investigate this
  79. mdosch Or tell old ejabberds to upgrade ^^
  80. mdosch Or tell old ejabberds to upgrade ^^
  81. mdosch Or tell old ejabberds to upgrade ^^
  82. lovetox should be fixed mdosch
  83. lovetox should be fixed mdosch
  84. lovetox should be fixed mdosch
  85. mdosch thx, will see tomorrow when the new nightly arrives :)
  86. mdosch thx, will see tomorrow when the new nightly arrives :)
  87. mdosch thx, will see tomorrow when the new nightly arrives :)
  88. mdosch btw, you fixed that the account alias is now also shown in accounts menu and when right clicking on "all accounts" but in mouseover on "all accounts" it's still example.com and example.com1 ^^
  89. mdosch btw, you fixed that the account alias is now also shown in accounts menu and when right clicking on "all accounts" but in mouseover on "all accounts" it's still example.com and example.com1 ^^
  90. mdosch btw, you fixed that the account alias is now also shown in accounts menu and when right clicking on "all accounts" but in mouseover on "all accounts" it's still example.com and example.com1 ^^
  91. lovetox ah thanks
  92. lovetox ah thanks
  93. lovetox ah thanks
  94. lovetox useless tooltip though
  95. lovetox useless tooltip though
  96. lovetox useless tooltip though
  97. mdosch yep, removing it wouldn't hurt i guess
  98. mdosch yep, removing it wouldn't hurt i guess
  99. mdosch yep, removing it wouldn't hurt i guess
  100. lovetox Link Mauve, current gajim-git aur package is broken
  101. lovetox Link Mauve, current gajim-git aur package is broken
  102. lovetox Link Mauve, current gajim-git aur package is broken
  103. lovetox because it doesnt depend on nbxmpp git
  104. lovetox because it doesnt depend on nbxmpp git
  105. lovetox because it doesnt depend on nbxmpp git
  106. lovetox or it does but it seems the nbxmpp package is not updated to newest git
  107. lovetox or it does but it seems the nbxmpp package is not updated to newest git
  108. lovetox or it does but it seems the nbxmpp package is not updated to newest git
  109. lovetox https://aur.archlinux.org/packages/python-nbxmpp-git/
  110. lovetox https://aur.archlinux.org/packages/python-nbxmpp-git/
  111. lovetox https://aur.archlinux.org/packages/python-nbxmpp-git/
  112. Link Mauve lovetox, -git packages don’t need to be updated, when you rebuild them they will fetch the latest commit of the branch they follow.
  113. Link Mauve lovetox, -git packages don’t need to be updated, when you rebuild them they will fetch the latest commit of the branch they follow.
  114. Link Mauve lovetox, -git packages don’t need to be updated, when you rebuild them they will fetch the latest commit of the branch they follow.
  115. lovetox why does it say then 0.5.6 in the headline
  116. lovetox why does it say then 0.5.6 in the headline
  117. lovetox why does it say then 0.5.6 in the headline
  118. lovetox ?
  119. lovetox ?
  120. lovetox ?
  121. Link Mauve The version number is updated as soon as you build it.
  122. Link Mauve The version number is updated as soon as you build it.
  123. Link Mauve The version number is updated as soon as you build it.
  124. lovetox i mean in the package details of the page
  125. lovetox i mean in the package details of the page
  126. lovetox i mean in the package details of the page
  127. lovetox i guess this is not updated automatically
  128. lovetox i guess this is not updated automatically
  129. lovetox i guess this is not updated automatically
  130. Link Mauve No, it isn’t, only when the user updates their system.
  131. Link Mauve No, it isn’t, only when the user updates their system.
  132. Link Mauve No, it isn’t, only when the user updates their system.
  133. lovetox a user reported that it is not working, but it seems it was a user error on the update
  134. lovetox a user reported that it is not working, but it seems it was a user error on the update
  135. lovetox a user reported that it is not working, but it seems it was a user error on the update
  136. bronko can the pkgver in the pkgbuild file be set to "git-HEAD" or something ? it is confusing at first when searching the aur website
  137. bronko can the pkgver in the pkgbuild file be set to "git-HEAD" or something ? it is confusing at first when searching the aur website
  138. bronko can the pkgver in the pkgbuild file be set to "git-HEAD" or something ? it is confusing at first when searching the aur website
  139. Link Mauve bronko, no, because the version is still compared to know whether you’re up to date or not.
  140. Link Mauve bronko, no, because the version is still compared to know whether you’re up to date or not.
  141. Link Mauve bronko, no, because the version is still compared to know whether you’re up to date or not.
  142. bronko the way i get it is: the pkgver() function in the pkgfile updates the pkgver variable when installing/upgrading the package, but the pkgver variable defined in line 6 is set to 0.5.6 which is older than the current stable, this was confusing to me
  143. bronko the way i get it is: the pkgver() function in the pkgfile updates the pkgver variable when installing/upgrading the package, but the pkgver variable defined in line 6 is set to 0.5.6 which is older than the current stable, this was confusing to me
  144. bronko the way i get it is: the pkgver() function in the pkgfile updates the pkgver variable when installing/upgrading the package, but the pkgver variable defined in line 6 is set to 0.5.6 which is older than the current stable, this was confusing to me
  145. Link Mauve bronko, correct.
  146. Link Mauve bronko, correct.
  147. Link Mauve bronko, correct.
  148. bronko can the pkgver _variable_ be set to git-head or something? it will be set correctly when installing
  149. bronko can the pkgver _variable_ be set to git-head or something? it will be set correctly when installing
  150. bronko can the pkgver _variable_ be set to git-head or something? it will be set correctly when installing
  151. Link Mauve No, otherwise AUR clients will not know whether they have to update or not.
  152. Link Mauve No, otherwise AUR clients will not know whether they have to update or not.
  153. Link Mauve No, otherwise AUR clients will not know whether they have to update or not.
  154. Link Mauve When this variable changes on AUR, clients will know they should update.
  155. Link Mauve When this variable changes on AUR, clients will know they should update.
  156. Link Mauve When this variable changes on AUR, clients will know they should update.
  157. bronko ok, so you need something to change when you upgrade the pkgfile?
  158. bronko ok, so you need something to change when you upgrade the pkgfile?
  159. bronko ok, so you need something to change when you upgrade the pkgfile?
  160. Link Mauve Since I always test my packages before pushing them, I simply upload the PKGBUILD with the updated pkgver.
  161. Link Mauve Since I always test my packages before pushing them, I simply upload the PKGBUILD with the updated pkgver.
  162. Link Mauve Since I always test my packages before pushing them, I simply upload the PKGBUILD with the updated pkgver.
  163. bronko got it, thanks!
  164. bronko got it, thanks!
  165. bronko got it, thanks!
  166. Tomek Hi, I use recent version of prosody with MAM installed and 2 clients with same account at the same time: conversations and gajim. When I disconnect conversations I can see it is able to retrieve archived messages (when it was off-line) from the server. Unfortunately gajim is not able to do the trick. What could be the reason? What do I miss?
  167. Tomek Hi, I use recent version of prosody with MAM installed and 2 clients with same account at the same time: conversations and gajim. When I disconnect conversations I can see it is able to retrieve archived messages (when it was off-line) from the server. Unfortunately gajim is not able to do the trick. What could be the reason? What do I miss?
  168. Tomek Hi, I use recent version of prosody with MAM installed and 2 clients with same account at the same time: conversations and gajim. When I disconnect conversations I can see it is able to retrieve archived messages (when it was off-line) from the server. Unfortunately gajim is not able to do the trick. What could be the reason? What do I miss?
  169. Tomek I use Gajim 0.16.8
  170. Tomek I use Gajim 0.16.8
  171. Tomek I use Gajim 0.16.8
  172. bronko Tomek, 0.16.8 does not support mam:2 (only mam:1) and if your server uses mam:2 gajim will not be able to get the history
  173. bronko Tomek, 0.16.8 does not support mam:2 (only mam:1) and if your server uses mam:2 gajim will not be able to get the history
  174. bronko Tomek, 0.16.8 does not support mam:2 (only mam:1) and if your server uses mam:2 gajim will not be able to get the history
  175. Tomek bronko: thanks, do you know if support is planned?
  176. Tomek bronko: thanks, do you know if support is planned?
  177. Tomek bronko: thanks, do you know if support is planned?
  178. bronko the current git:master supports it
  179. bronko the current git:master supports it
  180. bronko the current git:master supports it
  181. bronko there are also nightly builds available
  182. bronko there are also nightly builds available
  183. bronko there are also nightly builds available
  184. Tomek bronko, ok will try to install it, thx again
  185. Tomek bronko, ok will try to install it, thx again
  186. Tomek bronko, ok will try to install it, thx again
  187. Tomek bronko, I just installed gajim-nightly (mint 18) as described on official site. It still shows version 16.8 - is it normal? And I do not see it fetches archives
  188. Tomek bronko, I just installed gajim-nightly (mint 18) as described on official site. It still shows version 16.8 - is it normal? And I do not see it fetches archives
  189. Tomek bronko, I just installed gajim-nightly (mint 18) as described on official site. It still shows version 16.8 - is it normal? And I do not see it fetches archives
  190. bronko it seems that this is gajim-0.16.8-nightly, which i guess is 0.16.8 + a few fixes, you need the git version
  191. bronko it seems that this is gajim-0.16.8-nightly, which i guess is 0.16.8 + a few fixes, you need the git version
  192. bronko it seems that this is gajim-0.16.8-nightly, which i guess is 0.16.8 + a few fixes, you need the git version
  193. bronko Tomek, try this: https://dev.gajim.org/gajim/gajim/blob/master/README.md or maybe the debian exprimental might work under linuxmint: https://packages.debian.org/source/experimental/gajim (try at your own risk ;-) )
  194. bronko Tomek, try this: https://dev.gajim.org/gajim/gajim/blob/master/README.md or maybe the debian exprimental might work under linuxmint: https://packages.debian.org/source/experimental/gajim (try at your own risk ;-) )
  195. bronko Tomek, try this: https://dev.gajim.org/gajim/gajim/blob/master/README.md or maybe the debian exprimental might work under linuxmint: https://packages.debian.org/source/experimental/gajim (try at your own risk ;-) )
  196. Tomek bronk, tried, downloaded from debian, unpacked and installed; when running have fatal error that not in git repository... have no experience with that; now when reinstalled 0.16.8 have still same error: fatal: Not a git repository (or any parent up to mount point /home/tomek) Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set). 11/10/2017 00:39:21 (E) gajim.gtkgui_helpers Unable to load icon document-edit-symbolic: pygi-error: unknown error (0) Traceback (most recent call last): File "/usr/local/lib/python3.5/dist-packages/gajim/gajim.py", line 233, in _activate gtkgui_helpers.load_css() File "/usr/local/lib/python3.5/dist-packages/gajim/gtkgui_helpers.py", line 830, in load_css provider.load_from_data(bytes(css.encode())) GLib.Error: gtk-css-provider-error-quark: <data>:14:34'min-width' is not a valid property name (3) ... python-nbxmpp is already the newest version (0.6.0-1).
  197. Tomek bronko, see above