Gajim - 2017-06-10


  1. de-facto Guys the update before the current one totally broke dependencies in the debian repo: gajim-default-nightly 20170609-1 depends on python3-nbxmpp-nightly (>= 20160905) which was installed and working before. so now the autoupdate broke it and it wont start: "Gajim needs python-nbxmpp >= 0.5.6 to run. Quitting...". Well right so i break the package dependencies now on purpose to force it to work: "dpkg -r --force-depends python3-nbxmpp-nightly" which trashes the correct python3-nbxmpp-nightly (20170420-1), now gajim is dependency broken on purpose. apt badly complains now. well so i went and downloaded ftp://ftp.gajim.org/debian/dists/unstable/main/binary-all/python3-nbxmpp_0.5.6-1_all.deb and "dpkg -i python3-nbxmpp_0.5.6-1_all.deb" and YAY gajim starts with that older version it was desiring, yet now the dependencies are badly broken on my system
  2. de-facto this is ubuntu 17.04 amd64 and i didnt change anything except accepting the automatic update from gajim repo
  3. de-facto the one before the last one broke it i think
  4. de-facto i think it was gajim-default-nightly:amd64 20170602-1 -> 20170607-1
  5. de-facto if i am correct 20170602-1 was working still
  6. de-facto so with current state i either have broken dependencies or broken gajim
  7. lovetox its python3-nbxmpp-nightly
  8. lovetox which does not build correctly since a few days
  9. lovetox gajim nightly depends on nbmxpp nightly
  10. lovetox but nbxmpp nightly didnt build since a week, so its actually behind the normal package
  11. lovetox and gajim-nightly depends on 0.5.6 nbxmpp
  12. lovetox and nbxmpp nightly is currently on 0.5.5
  13. lovetox asterix trys to fix it over the weekend hopefully
  14. de-facto ah so the version in gajim-default-nightly was raised in 20170607-1 or so? because i cant see any updates from python3-nbxmpp-nightly at the update where it seems to break
  15. de-facto from nbxmpp 0.5.5 to 0.5.6?
  16. de-facto if i read the logs correctly, because after that i started fiddling with the deps
  17. lovetox yes i raised it
  18. lovetox not knowing that the nightly build did not work since weeks
  19. de-facto ah then i understand
  20. de-facto so it kinda works with python3-nbxmpp_0.5.6-1_all.deb so far... yet i bet it wants the nightlly version it actually depends upon (the .deb)
  21. lovetox thats only the package manager that wants that specific deb
  22. lovetox gajim doesnt care, nbxmpp is a python package and it imports it, if you install it via package manager or any other way doesnt matter
  23. de-facto yes apt wants python3-nbxmpp-nightly (>= 20160905) (which is 0.5.5?) and gajim itself "python-nbxmpp >= 0.5.6 to run"
  24. de-facto yep thats what i did, yet now apt always complains about broken gajim package
  25. lovetox yeah im not an expert on package managers, but if you can tell it to ignore that one dependency, and just install the stable it should work
  26. de-facto i can live with that for now, just wanted to make sure you guys know
  27. lovetox yeah asterix is working on it
  28. de-facto well i forced it on apt with dpkg the brutal way :P
  29. lovetox hope he gets it done this weekend
  30. de-facto yeah as long as he knows its perfectly fine :)
  31. fabio Is there any way to find out if any XEP is supported by the server?
  32. lovetox not in gernerell no
  33. lovetox you can look at the website of the server
  34. lovetox you can ask the admin of the server
  35. lovetox you can look at apps that support showing parts of the xeps
  36. lovetox like Conversations
  37. lovetox you can look at user made lists like that
  38. lovetox https://gultsch.de/compliance.html
  39. fabio OK, and does audio chat work on the windows version work? I wanted to try linux-windows chat, but my buddy says, that it is not supported.
  40. lovetox no windows does not have audio or video support
  41. fabio What a bummer. Thanks for the fast "support".
  42. lovetox for audio/video over xmpp you may want to look at jitsi