Gajim - 2016-11-12


  1. bot RSS: Feeds for Gajim • Ticket #8171 (Cannot create config file on startup (already exists)) updated Traceback (most recent call last): File "src\common\config.py", line 810, in _really_save File "src\gui_interface.py", line 2501, in save_config File "src\common\optparser.py", line 140, in write WindowsError?: [Error 183] Cannot create a file when that file already exists Gajim 0.16.5 GTK+ 2.24.10 PyGTK 2.24.0 Windows 10 Anniversary Edition[…] https://trac.gajim.org/ticket/8171#comment:2
  2. bot RSS: Feeds for Gajim Plugins • Changeset [1009:cdc8a9c02eb4]: Improve handling of empty/invalid devicelist[…] https://trac-plugins.gajim.org/changeset/cdc8a9c02eb44ba2fcbdc1f3aca680959b6c4ba0 • Changeset [1010:8e5145451caa]: Make PRAGMA settings after DB creation[] • Changeset [1011:e5e7ac96b279]: Update manifest.ini and CHANGELOG[]
  3. cuc hm omemo plugin upgrade from 0.9.5 to 0.9.7 did not go smooth
  4. cuc after upgrade its not "installed" and u could install it indefinitely it will never be shown in tab: "installed"
  5. cuc restarting gajim fixes that.. although plugin has to be enabled again...
  6. cuc latest stable gajim + ubuntu 1604 that is
  7. bullgard4 "A program error has been detected.
  8. bullgard4 Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/nbxmpp/dispatcher_nb.py", line 497, in dispatch handler['func'](session, stanza) File "/usr/share/gajim/src/common/connection_handlers.py", line 1868, in _messageCB conn=self, stanza=msg, account=self.name)) File "/usr/share/gajim/src/common/nec.py", line 76, in push_incoming_event self._generate_events_based_on_incoming_event(event_object) File "/usr/share/gajim/src/common/nec.py", line 98, in _generate_events_based_on_incoming_event if new_event_object.generate(): File "/usr/share/gajim/src/common/connection_handlers_events.py", line 1167, in generate if form['FORM_TYPE'] == 'urn:xmpp:ssn': File "/usr/lib/python2.7/dist-packages/nbxmpp/protocol.py", line 1721, in __getitem__ raise IndexError('No such field') IndexError: No such field
  9. bullgard4 "
  10. Martin Just for your information:
  11. Martin There is a bug report in Debian about python-gnomekeyring being deprecated.
  12. Martin https://bugs.debian.org/844156
  13. Link Mauve Martin, your information is wrong actually, the best forward path would be to use libsecret AFAIK.
  14. Link Mauve But the rest of the port (gtk3, g-i, gst-1.0, python3, etc.) is already in the default branch.
  15. Link Mauve I highly doubt it’s going to be ready before December though, there are still a huge amount of regressions and the lead dev doesn’t seem to have any time to give to the project currently.
  16. Martin Thanks! Is libsecret already supported by 0.16.6?
  17. Link Mauve It’s not, neither in the gajim_0.16 branch nor in the default one.
  18. Martin I see.
  19. Link Mauve I doubt it would take more than a few hours though, most changes would be code removal and documentation updates.
  20. Martin Maybe something for a 0.16.7 release?
  21. Link Mauve Is it possible to mix g-i with older PyGTK code?
  22. Martin I don't know.
  23. Link Mauve Martin, do you know of a mock object I could use to test with?
  24. Link Mauve Ugh, (gajim:15353): GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' is not installed
  25. Link Mauve And then it aborts.
  26. Martin Link Mauve, no - my own GTK programming experience is from many years ago, unfortunately :~(