Gajim - 2015-10-10


  1. bot RSS: Feeds for Gajim Plugins • Ticket #113 (Url image preview) updated You need gajim 0.16.4 as required by the manifest.ini. If you were able to upgrade with the plugin manager but not having 0.16.4 then a bug should be filed against gajim plugin manager. https://trac-plugins.gajim.org/ticket/113#comment:1
  2. Asterix Johannes: excellent!
  3. Asterix Johannes: are there many patches needed?
  4. Asterix Johannes: you use the default branch with GTK3 I guess?
  5. Johannes Currently there have not been that many, but it is far from reproducible or controlled
  6. Johannes Gtk3 from brew, yes
  7. Asterix ok nice
  8. Johannes Mostly comments. Currently there is some strange crash/error inside Gtk3 after one specific segfault
  9. Johannes I wonder if it would be reasonably possibly to create some sort of automatic integration test to validate things, using existing hosted or open tools
  10. Asterix insinde Gajim?
  11. Asterix we already have some tests
  12. Johannes Possible / acceptable effort
  13. Asterix definitly not enough. Very few in fact
  14. Johannes But it would require tests of the Guitar and with interaction to servers
  15. Johannes GUI... The glorious autocorrect
  16. Johannes For Webstuff you can use PhantomJS an selenium and the likes
  17. Johannes but I have no immediate idea what to use for gtk-stuff
  18. Asterix I don't know either. Never tested gui stuff
  19. Johannes http://ldtp.freedesktop.org/wiki/ that might actually be useful
  20. SouL w faixh
  21. faixh SouL, ?
  22. SouL Sorry, I don't know why I typed that lol
  23. SouL My bad, faixh :P
  24. bot RSS: Feeds for Gajim • Ticket #8164 (Error in emoticons_pack.py) closed invalid: It's a plugin issue. Ticketed ​there https://trac.gajim.org/ticket/8164#comment:1
  25. bot RSS: Feeds for Gajim Plugins • EmoticonPac[] • WikiStart e[] • [] • Ticket #114 (Error loading zip file) created reported ​here Bug description When running gajim on windows and having emoticons plugin installed one gets the following error when trying to open the plugins dialogue and/or go to Emoticons tab there: Traceback (most recent call last): File "[…] https://trac-plugins.gajim.org/ticket/114 • Ticket #114 (Error loading zip file[] • Changeset [695:3c8e529e[] • Ticket #114 (Error load[]