Gajim - 2015-06-25


  1. profpatsch I’m at a loss.
  2. profpatsch gajim-remote wants to call ht
  3. profpatsch *hg
  4. profpatsch And I cannot find where the code wants to call it.
  5. profpatsch It tries to call it in its source dir: abort: no repository found in '/nix/store/pqr3isj7c4aizqs0hb7c1hpgl7ca29dd-gajim-0.16.1/share/gajim/src' (.hg not found)!
  6. profpatsch the heck
  7. bot RSS: Feeds for Gajim • Ticket #8091 (gaijim-remote tries to call hg) created Bug description I get the error /bin/sh: hg: command not found to stderr. It happens before the message that Gajim is not running. When mercurial is installed the message is: abort: no repository found in '/nix/store/22niy1x8scasa1dh066mxpx4m0mlpz95-gajim-0.16.1/share/gajim/src' (.hg not found)! on my NixOS, which resembles <..>/share/gajim[…] https://trac.gajim.org/ticket/8091
  8. bot RSS: Feeds for Gajim • Ticket #8092 (Overrides ~/.config/gajim/config symlink) created Bug description When config is a symlink it gets overridden on startup. Steps to reproduce move config, link to it’s new place restart gajim config is a plain file again, link is deleted Software versions OS version: nixos 2015-06-25 (master) GTK version: 3.16.2 PyGTK version: 2.0.16 https://trac.gajim.org/ticket/8092
  9. moparisthebest does gajim pgp encrypt to my key as well? it doesn't seem like it because my other clients that get the message carbon can't decrypt it?
  10. Link Mauve moparisthebest, you should open a bug on the trac, so that your issue doesn’t get lost in the logs.
  11. moparisthebest yes I just wanted to check with others to see if it actually is a bug
  12. Link Mauve I haven’t used Gajim in years, so I can’t really help you with that. :(
  13. moparisthebest also I should check with the latest 0.16.1 first, I'm still on 0.15.4
  14. moparisthebest if you don't mind what do you use?
  15. Link Mauve poezio
  16. Link Mauve A pretty well-made console client.
  17. mathieui except the GPG plugin sucks and is probably buggy
  18. Link Mauve Heh. ^^'
  19. moparisthebest well I upgraded to the latest gajim to see if the issue is fixed and it's almost worse hehe
  20. moparisthebest it must mark the pgp message private, because it doesn't even show up as a carbon on the other device
  21. moparisthebest which entirely defeats the purpose of using pgp vs otr
  22. bot RSS: Feeds for Gajim • Ticket #7616 (Gajim should properly flag encrypted messages when using OTR with Message …) updated This is incorrect, at least for GPG messages, which should be encrypted to the recipient's key AND your key, so message carbons with another one of your GPG-enabled clients work as intended. For example, if I send a gpg encrypted message from my Conversati[…] https://trac.gajim.org/ticket/7616#comment:7 • Ticket[…] https://trac.gajim.org/ticket/7616#comment:8
  23. moparisthebest that was me, that ticket mentioned OTR which should indeed disable carbon copy
  24. moparisthebest but GPG should not disable it, in fact that's why you'd choose GPG over OTR, so that carbons work
  25. moparisthebest is gajim 0.16.1 supposed to be for python 3 now or what? when I try to run it I get
  26. moparisthebest File "gajim.py", line 238 print(_('Gajim needs X server to run. Quiting...'), file=sys.stderr) ^ SyntaxError: invalid syntax
  27. moparisthebest uh, the error is at file=, because that looks like python 3 syntax?
  28. Link Mauve Nope, only default.
  29. Link Mauve The branch that will become 0.17 someday.
  30. moparisthebest ah ok I have to check out the 0.16.1 tag got it :)