Gajim - 2014-02-20


  1. Patrik Marschalik Hi fedor.brunner, I am using python-openssl 0.13-2+deb7u1. And no there are no error messages displayed. It just happens nothing.
  2. bot RSS: Feeds for Gajim • Ticket #7661 (traceback) updated Addition. Not always hangs when displaying hint. But always hangs when, hint is in the foreground. Only helps the completion of the process. Perhaps gajim work becau[…] https://trac.gajim.org/ticket/7661#comment:5 • Ticket #7664 (don't show popup menu on transports) created Traceback in console: Traceback (most recent call last): File "/home/users/staff/terminator/soft/gajim/src/roster_window.py", line 3[…] https://trac.gajim.org/ticket/7664
  3. Link Mauve Asterix, now that you use mod_pastebin, it could be better to make bot say the entire descriptions of tickets, no?
  4. Patrik Marschalik was hast du heute noch so vor?
  5. Patrik Marschalik sorry wrong tab….
  6. SouL x)
  7. Darlan dicson, open disco: gajim.org > Select and Browse conference.gajim.org > Select and Join gajim@conference.gajim.org > Dialog transient for roster.
  8. Darlan Disco dialog should be a managed within a wizard so we would not need to be bothered by these popup dialogs.
  9. pvtlth Hey guys! I can't believe Gajim 0.16 is still in beta2. What's going wrong there?
  10. pvtlth Is it stable?
  11. pubis I am also waiting for the final release ;)
  12. Asterix pvtlth, maybe you have more time than me to test / integrate audio / video for windows?
  13. pvtlth Sorry, I'm not using Windows and I don't know python too well...
  14. Darlan Asterix, are you intend on having Audio/Video to work on Windows with Gajim 0.16?
  15. Darlan Asterix, are you intending on having Audio/Video to work on Windows with Gajim 0.16?
  16. Asterix yes
  17. pvtlth Let's try beta2 on linux!
  18. Dr. Watson So I just downloaded Gajim beta 2 and it didn't work because it wanted to get some plugins and an ftp error ocurred. So I restarted. Now I got an error with beta2. So I started Gajim 0.15.4 again and the same error ocurred.
  19. Dr. Watson The error message was: Traceback (most recent call last): File "gajim.py", line 472, in <module> interface.run() File "/usr/share/gajim/src/gui_interface.py", line 2537, in run gajim.plugin_manager = plugins.PluginManager() File "/usr/share/gajim/src/plugins/helpers.py", line 129, in __call__ cls.instance=super(Singleton, cls).__call__(*args,**kw) File "/usr/share/gajim/src/plugins/pluginmanager.py", line 104, in __init__ pc = PluginManager.scan_dir_for_plugins(path) File "/usr/share/gajim/src/plugins/helpers.py", line 114, in wrapper result = f(*args, **kwargs) File "/usr/share/gajim/src/plugins/pluginmanager.py", line 441, in scan_dir_for_plugins module = __import__(module_name) File "/usr/share/gajim/src/common/demandimport.py", line 95, in _demandimport return _import(name, globals, locals, fromlist, level) File "/home/luis/.local/share/gajim/plugins/gotr/__init__.py", line 1, in <module> from otrmodule import OtrPlugin File "/usr/share/gajim/src/common/demandimport.py", line 114, in _demandimport mod = _origimport(name, globals, locals) File "/home/luis/.local/share/gajim/plugins/gotr/otrmodule.py", line 75, in <module> sys.path.insert(0, os.path.dirname(ui.__file__)) File "/usr/share/gajim/src/common/demandimport.py", line 86, in __getattribute__ self._load() File "/usr/share/gajim/src/common/demandimport.py", line 58, in _load mod = _origimport(head, globals, locals) File "/home/luis/.local/share/gajim/plugins/gotr/ui.py", line 433 ^ SyntaxError: invalid syntax
  20. Dr. Watson enjoy the debugging!
  21. Darlan Dr. Watson, do you python-nbxmpp installed?
  22. Dr. Watson wait for it...
  23. Dr. Watson wait for it... some more...
  24. Dr. Watson nope, I'll get it right away
  25. Dr. Watson still broken
  26. Dr. Watson reinstalling 0.15.4
  27. Asterix Dr. Watson, try to remove the otr plugin in ~/.local/share/gajim/plugins/
  28. Dr. Watson I just got it running again by renaming /home/username/.local/share/gajim/plugins/
  29. Asterix you can just remove the gotr folder from there and re-installing it
  30. Dr. Watson it worked
  31. Dr. Watson no problems with 0.15.4 and no idea what caused the problem... I will wait for 0.16 leave beta status.
  32. pvtlth is worrying about lots of "(gajim:15498): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed" error messages thrown into terminal (using 0.15.4)
  33. Darlan What is this error? Traceback (most recent call last): File "/usr/share/gajim/src/conversation_textview.py", line 889, in on_start_chat_activate gajim.interface.new_chat_from_jid(self.account, jid) File "/usr/share/gajim/src/gui_interface.py", line 2200, in new_chat_from_jid resource=resource) File "/usr/share/gajim/src/gui_interface.py", line 2177, in new_chat chat_control = ChatControl(mw, contact, account, session, resource) File "/usr/share/gajim/src/chat_control.py", line 1702, in __init__ gajim.plugin_manager.gui_extension_point('chat_control', self) File "/usr/share/gajim/src/plugins/helpers.py", line 114, in wrapper result = f(*args, **kwargs) File "/usr/share/gajim/src/plugins/pluginmanager.py", line 181, in gui_extension_point *args) File "/usr/share/gajim/src/plugins/helpers.py", line 114, in wrapper result = f(*args, **kwargs) File "/usr/share/gajim/src/plugins/pluginmanager.py", line 258, in _execute_all_handlers_of_gui_extension_point handlers[0](*args) File "/home/etf/.local/share/gajim/plugins/gotr/otrmodule.py", line 329, in cc_connect cc.update_otr(True) File "/home/etf/.local/share/gajim/plugins/gotr/otrmodule.py", line 313, in update_otr self.get_otr_status(cc.account, cc.contact) File "/home/etf/.local/share/gajim/plugins/gotr/otrmodule.py", line 303, in get_otr_status ctx = self.us[account].getContext(contact.get_full_jid()) KeyError: u'linuxlovers.at'
  34. Darlan Right click > Start chat > Error.
  35. pvtlth Maybe something doesn't expect u'linuxlovers.at' as return value?
  36. Darlan Maybe. I also receive each Single Message 5 - 6 times, on LinuxLovers server.
  37. Darlan After restarting Gajim, linuxlovers.at account worked well.
  38. Darlan Maybe gotr bug.
  39. bot RSS: Feeds for Gajim • Changeset [15360:5ccb2dae7ded]: [Darlan] Update Hebrew translation [Darlan] Update Hebrew translation https://trac.gajim.org/changeset/5ccb2dae7ded88d1a87dfb290f94118015bcac06
  40. Darlan Something is wrong at. -msgid "The authenticity of the %s certificate could be invalid." +msgid "The authenticity of the %s certificate could be invlid"
  41. Darlan x11term, how do you run GTK+ 3 version of Gajim?
  42. patrik I tried connecting to jabber.uni-mainz.de with the latest nightly and python-openssl 0.13.1-1 but still no luck and no error messages. With other clients it works. I have no idea what the problem could be. Any hints?
  43. Asterix patrik, could you run gajim -v to see what happens?
  44. patrik Asterix, there are a lot of messages of the type 20.02.2014 23:23:02 (I) nbxmpp.transports_nb pollout called, state == CONNECTED
  45. patrik ...is this what you want to know?