Gajim - 2013-01-26


  1. Natureshadow No stacktrace is produced either
  2. bot RSS: Feeds for Gajim Plugins • Changeset [502:e874b9fa1986]: ClientsIconsPlugin.py3 gtk3 ClientsIconsPlugin.py3 http://trac-plugins.gajim.org/changeset/e874b9fa19866e8b670cf0a5c09d2b42b2f1bd11
  3. mmlosh Can Custom status be sent to a MUC?
  4. dicson can try in xml console
  5. bot RSS: Feeds for Gajim • Changeset [14346:2c3b3ecd0c18]: fix browsing muc components gtk3 fix browsing muc components https://trac.gajim.org/changeset/2c3b3ecd0c18ef4f52d95360063a95d10a343c7b • Changeset [14347:f61b0d6163e0]: fix XML window gtk3 fix XML window https://trac.gajim.org/changeset/f61b0d6163e002142d683609cdf0ce40b3bd2670
  6. Asterix dicson: Hi, I saw you started a gtk3 plugin?
  7. dicson Asterix, Hi. Yes,I try
  8. Asterix is it working?
  9. dicson yes
  10. dicson http://dicson.no-ip.info/apache2-default/screenshots/2013-01-26_22:59:43.png
  11. Asterix ok. So I'll setup the ftp.
  12. Asterix but ...
  13. Asterix I'm thinking that the plugins we have on our machine will make Gajim fail until they are ported to gtk3.
  14. dicson and I will fix plugin installer after it
  15. Asterix so I'm thinking about adding a min_gajim_version and max_gajim_version in the manifest file
  16. dicson it is not help
  17. dicson we need remove all plugins after update to gtk3
  18. dicson I think
  19. Asterix not if there is a max_gajim_version
  20. Link Mauve Not remove, disable, because some users may want to go back to gtk2 version for some reason.
  21. Asterix plugin system won't try to load it if we have a too new Gajim version
  22. dicson hm
  23. maksymov hello!
  24. dicson Asterix, maybe you right
  25. Asterix Hello maksymov
  26. Asterix Link Mauve: the problem is that there is no way to downgrade plugins
  27. Link Mauve How is the update system currently? If it isn’t automated it could lead to a painful experience, like back in the time with Firefox.
  28. maksymov sorry for off-top, :) Gajim is perfect except network-manager integration and audio/video call
  29. Link Mauve Now they solved it by having addons being assumed to work, except if they have been reported to not work.
  30. maksymov I can't help, but I hope you will fix that! ^)
  31. Asterix Link Mauve: the plugin system? On Gajim startup Gajim checks if there are new version of installed plugins and propose to user to d/l it
  32. Asterix maksymov: things work for me, so no don't hope too much for me to fix a working feature. Now if you have problems, don't hesitate to explain them
  33. dicson if autoupdate is checked
  34. Asterix right
  35. Link Mauve It isn’t by default?
  36. Asterix it is by default
  37. maksymov Asterix, I know english a little, but I'll try
  38. Asterix dicson: ftp://ftp.gajim.org/plugins-gtk3 is ready. Now working on min/max_gajim_version
  39. dicson ok.thanks!
  40. dicson Now trying to fix maksymov nm problem
  41. Asterix which pb?
  42. dicson maksymov insert print (nm_state) in network_manager_listener.py and now n-m integration works fine :-|
  43. Asterix ha ... funny
  44. dicson Asterix, network-manager and Gajim
  45. dicson nm_state can be:
  46. dicson NM_STATE_CONNECTED_LOCAL = 50 A network device is connected, but there is only link-local connectivity. NM_STATE_CONNECTED_SITE = 60 A network device is connected, but there is only site-local connectivity. NM_STATE_CONNECTED_GLOBAL = 70 A network device is connected, with global network connectivity.
  47. dicson maybe we need nm_state > 40 instead nm_state = 70? I not understand what is the difference
  48. Asterix dicson: min/max_gajim_version is ready
  49. bot RSS: Feeds for Gajim Plugins • Changeset [503:c7b660ac1128]: new client icon plugin require gtk3 branch of Gajim gtk3 new client icon plugin require gtk3 branch of Gajim http://trac-plugins.gajim.org/changeset/c7b660ac112808dec19735c6bc7f30bc0dc16302
  50. bot RSS: Feeds for Gajim • Changeset [14348:23de2f5dd58a]: support min_gajim_version and max_gajim_version in plugins gtk3 support min_gajim_version and max_gajim_version in plugins https://trac.gajim.org/changeset/23de2f5dd58a8468260677f4de8f463ba0d33dfe
  51. bot RSS: Feeds for Gajim Plugins • Changeset [504:506c5b9ed20c]: all plugins don't work in gtk3 for the moment default all plugins don't work in gtk3 for the moment http://trac-plugins.gajim.org/changeset/506c5b9ed20c77755a59456efa938dbede12e7ae • Changeset [505:dcd6be068e11]: all plugins don't work in gtk3 for the moment gtk3 all plugins don't work in gtk3 for the moment http://trac-plugins.gajim.org/changeset/dcd6be068e11c984e1b5625d5629fd2a29fde366